URL link is not working / HTML tag is displayed

VERIFIED FIXED in 6.3.0

Status

defect
--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: johnny.mozbugs, Assigned: spasovski)

Tracking

unspecified
6.3.0
Dependency tree / graph

Details

Attachments

(2 attachments)

Reporter

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

1. Register a new user at https://addons-dev.allizom.org/en-us/firefox/users/register
2. Try to log in.



Actual results:

The warning message with "Send Activation Email" appears. Below, there is the "Having Trouble" section. The URL for resending the activation email appears as a normal text because the <a href=></a> HTML tags were written instead of being interpreted.

"Having Trouble?

If you did not receive the confirmation email, make sure your email service did not mark it as "junk mail" or "spam". If you need to, you can have us <a href="https://addons-dev.allizom.org/en-us/firefox/user/5900955/confirm/resend">resend the confirmation message</a> to your email address mentioned above.
"


Expected results:

The URL should be clickable. A valid link should be displayed.
Reporter

Comment 1

8 years ago
I have manually copy/pasted the link into the browser and I have received another request of Activation Email, so the link is working fine, just the appearance is the issue here.

Updated

8 years ago
Blocks: 560978

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Updated

8 years ago
Severity: normal → major
Target Milestone: --- → 6.3.0
Assignee

Comment 2

8 years ago
I got this.
Assignee: nobody → dspasovski
Assignee

Comment 3

8 years ago
Done: https://github.com/mozilla/zamboni/commit/788e5d1f
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Reporter

Comment 4

8 years ago
Posted image postfix screenshot
Verified fixed. 
Resend confirmation URL is displayed correctly now.
Reporter

Updated

8 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.