If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

QP encoded subjects with space inside is displayed QP coded

VERIFIED FIXED

Status

MailNews Core
MIME
--
major
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: Leif Halvard Silli, Assigned: John G. Myers)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.8) Gecko/20010215
BuildID:    2001021502

A MIME encoded (ISO-8859-1) Subject as sent out by Eudora is not decoded by
Mozilla. This was no problem in Netscape 4.7x. Even if both 4.7x and Mozilla
themselves encode only the single non-ascii strings instead of the whole subject
line.


Reproducible: Always
Steps to Reproduce:
You must fetch a mail sent out by Eudora with a subject containg MIME encoded
non-ASCII letters, e.g. Norwegian å (å).

Actual Results:  After fetching such a message you will see that the subject has
not become decoded at all. So the subject will look exactly like the code.

Expected Results:  Normal decoding. No code display in the subjet. I don't know
the RFC but Eudora is a major player in this game. Also other mailers encode
messages the same way (e.g. Magellan and Nisus Email,both Mac mailers.)

*Sample of how Eudora [3.1 for Mac] encode such a line:
'Subject: Re: =?ISO-8859-1?Q?Er du g=E5tt i dekning??='

Note that *the whole* subject content is included in the MIME enc. Whereas
Mozilla and Netscape4.7 would encode the each non-ASCII string/letter *inside*
the subject content, like in this Mozilla 0.8 sample:

'Subject: Re: Er du =?ISO-8859-1?Q?g=E5tt?= i dekning?'

Comment 1

17 years ago
*** Bug 69252 has been marked as a duplicate of this bug. ***

Comment 2

17 years ago
I can confirm that this line doesn't decode:
Subject: Re: =?ISO-8859-1?Q?Er du g=E5tt i dekning??=

Working (displaying properly) is:
Subject: =?iso-8859-1?Q?H=E4pp_igen_(NT)?=
Subject: Re: Er du =?ISO-8859-1?Q?g=E5tt?= i dekning?
Subject: Re: =?ISO-8859-1?Q?Er_du_g=E5tt_i_dekning??=

The culprit seems to be the spaces inside the quoted printable text. Maybe they 
are disallowed by the standard, but we could be helpful anyway if the text 
decodes with that relaxation of the rules. Then I don't now the rules for QP 
coding MIME headers, so maybe we got a bug.

I tested with a newer Eudora (version 4.3) on Windows and it doesn't code 
including the spaces. That's the first of the three "working" subjects above.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: MIME encode subjects from Eudora is not decoded → QP encoded subjects with space inside is displayed QP coded
(Assignee)

Comment 3

17 years ago
Taking.
Assignee: ducarroz → jgmyers
(Assignee)

Comment 4

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
QA Contact: esther → stephend
sending leak/opt bugs over to my other bugzilla account
QA Contact: stephend → stephen.donner
QA Contact: stephen.donner → esther

Comment 6

16 years ago
Using build 20020322 on winxp and 20020318 on mac and linux
I sent myself a message uisng Eudora 5.1 with non-ascii characters in the
subject. this is displayed when reading the source
Subject: =?iso-8859-1?Q?=C7=FC=EF=E9=E2=E4=E0=E5=E7=EA=EB=E8=EF?=  
but displays as correctly in the message pane subject field as 
Subject: Ηόοιβδΰεηκλθο 
  
Verified. 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.