Copying the host name from the URL also copies the HTTP prefix.

RESOLVED DUPLICATE of bug 689342

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 689342
6 years ago
6 years ago

People

(Reporter: Florian Fischer, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

I pulled down an URL from my bookmarks, for example:
   http://hostname.mycompany.com:port/application/service/page.jsp.
The location bar displayed
   hostname.mycompany.com:port/application/service/page.jsp.
I then wanted to copy the host name.  I selected "hostname.mycompany.com" and pressed ctrl-C.
I then went to an editor and pasted the text.


Actual results:

The text pasted to my editor was "http://hostname.mycompany.com"



Expected results:

The text pasted to my editor should have been what I selected, "hostname.mycompany.com"

Note:
I understand that when copying a complete URL with ctrl-A ctrl-C, it should include the http:// prefix.  But if a specific portion of the URL was selected, ignoring the http:// prefix would sometimes be a better choice.

I think the http:// prefix should be excluded if the selection doesn't include the whole URL from the start to the first '/' after the host or the end-of-line.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689342
You need to log in before you can comment on or make changes to this bug.