Sluggish graphics performance on Intel HD Graphics

RESOLVED DUPLICATE of bug 621335

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 621335
6 years ago
6 years ago

People

(Reporter: Marcin Kowalski, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20110928060149

Steps to reproduce:

Regular browser usage on Dell Lattitude E6510 with integrated Intel HD graphics.


Actual results:

Graphics performance is very sluggish, which is mostly visible when opening/closing new tabs (lag, tab animation). Also, viewmarks plugin performs extremally slow (takes ~2 seconds to paint 10 thumbnails), although it has nothing to do with the plugin. Even menus seem to draw slowly. This is miles away from how chrome performs.


Expected results:

Performance should be much better, smooth graphics and animation. When I changed settings in about:config to:

gfx.direct2d.disabled = true (from false)
gfx.font_rendering.directwrite.enabled = false (from true)

, it seems to perform much better, but still not perfect. There is no way to guess these settings for regular users.

Comment 1

6 years ago
Those settings can be done from the Preferences window (tools->advanced->enable HW acceleration ->off).
Can you post the Graphics section of about:support with HW accel enabled?
(Reporter)

Comment 2

6 years ago
Here comes the graphics section. Field names are in polish, but you will figure it out,

        Opis adaptera
        Intel(R) HD Graphics

        ID dostawcy
        8086

        ID urządzenia
        0046

        RAM adaptera
        Unknown

        Sterowniki adaptera
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Wersja sterownika
        8.15.10.2281

        Data sterownika
        1-12-2011

        Vendor ID (GPU #2)
        8086

        Device ID (GPU #2)
        0046

        Adapter RAM (GPU #2)
        Unknown

        Adapter Drivers (GPU #2)
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Driver Version (GPU #2)
        8.15.10.2281

        Driver Date (GPU #2)
        1-12-2011

        Włączone Direct2D
        true

        Włączone DirectWrite
        true (6.1.7601.17563)

        Parametry ClearType
        Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400

        Renderer WebGL
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)

        Okna ze sprzętowym przyspieszeniem grafiki
        1/1 Direct3D 10

Comment 3

6 years ago
Well, what is the model number of the Intel card? It seems it doesn't report it.
It is this notebook http://www.dell.com/us/business/p/latitude-e6520/pd#TechSpec ?

You can then update your graphics driver.

And then you can try this benchmark http://demos.hacks.mozilla.org/openweb/HWACCEL/ and tell us what is the difference in fps (HW accel on and off).
BTW, you can get recent Driver on http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=20389&ProdId=3231&lang=eng&OSVersion=Windows%207*&DownloadType=Drivers
Err, sorry. Should be http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3231&DwnldID=20391&ProductFamily=Graphics&ProductLine=Laptop+graphics+controllers&ProductProduct=Intel%AE+HD+Graphics&lang=eng since you're on 64-Bit :-)
(Reporter)

Comment 6

6 years ago
This is dell latitude E6510. I don't know exact model number of the card, but it is Intel i7 M620 2.67MHz integrated HD graphics.

The http://demos.hacks.mozilla.org/openweb/HWACCEL/ benchmark gives me 5fps without hw acceleration and 37fps _with_ hw acceleration. So, much faster... But, the overall user interface performance is much much SLOWER with hw accel on. Opening/closing tabs, scrolling, menu drawing etc is very very sluggish. It is nice, that this benchmark gives such a good results when fx is hardware accelerated, but at the same time hardware acceleration seems to ruin ui drawing performance, so I'm turning it off and waiting for some hints/patches.

I have seen other users having similar complaints somewhere on mozilla support forums, so it is not like I'm the only one affected.

Thanks,

Comment 7

6 years ago
Maybe the card is just not powerful enough to accelerate the kind of operations needed for the GUI while it is enough for the page content. According to the dell page I linked it could be Intel HD 3000 Graphics. If you have this in an Sandy Bridge CPU I think Intel is still making progress on polishing drivers for that family.
Have you updated the driver as suggested?

Could you point as at some of the reports in the forums?

Do you have Internet Explorer 9 on that machine? How does that perform?
(Reporter)

Comment 8

6 years ago
Yes, I have updated the driver as you suggested.

Both Internet Explorer 9 and Chorme 14 perform ok. They are smooth and fast (as far as IE can be...). Firefox is definitely MUCH slower in terms of UI rendering, scrolling, etc. and is much less responsive when HW acceleration is on.

This is the thread I mentioned before: http://support.mozilla.com/pl/questions/795112

Comment 9

6 years ago
Then please paste the about:support->Graphics again.

Unfortunately that linked support page is quite a mess of various issues. And it is about Firefox 4, many people are on XP, disabling HW acceleration didn't fix the slowness for them. Only one comment that I can see says disabling HW accel fixed it for him but he is on XP. So that thread seems not very relevant here.

I do not have any Win7 machine available so I can't confirm this problem myself. Therefore I ask need somebody (you) to find other real confirmations (from other users) about this bug. Then I am willing to confirm this bug due to "popular request".

You can also try to leave HW accel on, but go to about:config, find layers.acceleration.disabled and set it to true.
(Reporter)

Comment 10

6 years ago
I agree that this thread is quite a mess. But it also says, that 1170 people report it. I couldn't find any other similar reports online. It's up to you if you tackle this problem.

Please mind, that firefox is the only app on my PC that has such issue.

about:support->Graphics again:

        Opis adaptera
        Intel(R) HD Graphics

        ID dostawcy
        8086

        ID urządzenia
        0046

        RAM adaptera
        Unknown

        Sterowniki adaptera
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Wersja sterownika
        8.15.10.2509

        Data sterownika
        8-31-2011

        Vendor ID (GPU #2)
        8086

        Device ID (GPU #2)
        0046

        Adapter RAM (GPU #2)
        Unknown

        Adapter Drivers (GPU #2)
        igdumd64 igd10umd64 igdumdx32 igd10umd32

        Driver Version (GPU #2)
        8.15.10.2509

        Driver Date (GPU #2)
        8-31-2011

        Włączone Direct2D
        true

        Włączone DirectWrite
        true (6.1.7601.17563)

        Parametry ClearType
        Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400

        Renderer WebGL
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)

        Okna ze sprzętowym przyspieszeniem grafiki
        1/1 Direct3D 10

Comment 11

6 years ago
OK. I assume you have Windows 7 Service Pack 1(SP1) and KB2505438 update installed.

Can you make these tests with HW acceleration enabled?
Test1:
Go to about:config, find layers.acceleration.disabled and set it to TRUE.

Test2:
Go to about:config, find layers.acceleration.disabled and set it to false. Find gfx.direct2d.disabled and set it to TRUE.

Does any of these settings cause any change?
(Reporter)

Comment 12

6 years ago
Yes, the mentioned updates are installed.

Test1: does not change anything, still sluggish
Test2: Firefox behaves as if hw acceleration was disabled. I wouldn't call it smooth, but ui is visibly faster

Comment 13

6 years ago
Ok, so it seems Direct2D is slowing it down. You should still see Direct3D 10 acceleration enabled in about:support. I will confirm the bug so that the graphics people can look at it. If Direct2D really is slower than no acceleration, then maybe this card should be blacklisted.
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
(Reporter)

Comment 14

6 years ago
Take a look at these:

https://bugzilla.mozilla.org/show_bug.cgi?id=621335
https://bugzilla.mozilla.org/show_bug.cgi?id=688050

Comment 15

6 years ago
Great, thanks, let's move there.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621335
You need to log in before you can comment on or make changes to this bug.