Closed Bug 69276 Opened 21 years ago Closed 21 years ago

Browser window should (optionally) not pop to front when page loaded

Categories

(SeaMonkey :: General, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 28467

People

(Reporter: lars-bugzilla, Assigned: hangas)

Details

This is a matter of opinion, so should probably be optional, but it annoys me!
[sorry ;-)]

If I start a page loading in Mozilla and then switch to another application (eg.
KMail, but it could be anything), when the page has finished loading, the
browser window pops to the front, interrupting what I'm doing.

I would rather (a) leave one or more web pages loading in the background and (b)
come back to them when I'm ready; usually they'll be loaded and ready to read by
then.

An option to do one of the following on page load would be nice:
- nothing
- beep
- play a sound
- pop to front (as it does now)
- run a program specified by the user
- play the national anthem (determined by locale settings) ;-)

but if that's not possible, I think the 'nothing' option is more useable and safe
 - it's quite annoying when you go to click on something in another app, and
suddenly a web browser appears in view and you end up clicking on a link instead
(especially if the link says "click here to confirm your order and charge your
credit card"!)
dupe of 28467, see also bug 55691.

*** This bug has been marked as a duplicate of 28467 ***
Status: UNCONFIRMED → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
vrfy dupe of mostfreq bug 28467 Windows switch z-order when running a URL
Status: RESOLVED → VERIFIED
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.