Last Comment Bug 692826 - nsIEntropyCollector and nsIScriptChannel interfaces missing in build due to overwriting dom.xpt from plugins
: nsIEntropyCollector and nsIScriptChannel interfaces missing in build due to o...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla10
Assigned To: Mook (as)
:
Mentors:
http://mxr.mozilla.org/mozilla-centra...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-07 09:56 PDT by Mook (as)
Modified: 2011-10-17 02:50 PDT (History)
3 users (show)
mook.moz+mozbz: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
remove incorrect MODULE= line from dom-config.mk (504 bytes, patch)
2011-10-07 10:00 PDT, Mook (as)
benjamin: review+
Details | Diff | Review

Description Mook (as) 2011-10-07 09:56:55 PDT
http://mxr.mozilla.org/mozilla-central/source/dom/dom-config.mk?mark=1-1&rev=bd1411e362fb sets MODULE=dom which overrides http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/Makefile.in?rev=15bfad783467&mark=45#37 causing it to overwrite dom.xpt from http://mxr.mozilla.org/mozilla-central/source/dom/base/Makefile.in?rev=15bfad783467&mark=45-45#37 .

Found this because I had silly code walking all interfaces and didn't deal with failure correctly.  It failed looking at nsIBufEntropyCollector because the parent interface failed to resolve.

Will attach a patch in a second, I need a bug number for the proper commit message first :)
Comment 1 Mook (as) 2011-10-07 10:00:28 PDT
Created attachment 565566 [details] [diff] [review]
remove incorrect MODULE= line from dom-config.mk
Comment 2 :Mook 2011-10-16 22:25:18 PDT
Pushed to mozilla-inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/d2241309d83c

(This was also pushed to try, https://hg.mozilla.org/try/rev/afccba9817a4, linux64 debug+release only, both green)

This is fine to close on inbound->m-c merge.
Comment 3 Marco Bonardo [::mak] 2011-10-17 02:50:18 PDT
https://hg.mozilla.org/mozilla-central/rev/d2241309d83c

Note You need to log in before you can comment on or make changes to this bug.