Thunderbird print scaling on Mac OS X is reversed after the first page.

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
major
RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: realgrouchy, Unassigned)

Tracking

7 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

316.29 KB, application/pdf
Details
(Reporter)

Description

7 years ago
When viewing a message that would print to more than one page (either in the preview pane or in its own message tab). I want to scale down the printing to reduce the amount of space it occupies. However, only the first page is scaled down.

I have been able to reproduce this with all add-ons disabled; I am using the default skin.

Steps to reproduce:
1. In Thunderbird 7 on OS X (10.6.8) Go to File > Page Setup

2. In the top line of the dialog that appears, navigate to the desired printer. In the bottom line (Scale), enter 90 (%).

3. Navigate to a message somewhere in Thunderbird that would go to more than one page. Go to File > Print...

4. The bug occurs whether or not you have selected "Ignore Scaling and Shrink To Fit Page Width"

5. Print (or click on "Preview").

Result 1: The first page correctly scales the content so that more content appears in smaller print. Subsequent pages, however, are scaled inverse, as though the 'box' for the printable area scales down, but the 'box' containing the content (including headers and footers) is not scaled. IOW, the content appears to be scaled to the inverse of 90%, and bleeds off the page.

6. Repeat the above with a scale factor of 110%:

Result 2: The first page correctly scales up the content so that the text wrapping correctly displays at the higher scaling. Subsequent pages show the content as though the 'box' for the printable area scales up, but the 'box' containing the content (including headers and footers) is not scaled. IOW, the content appears scaled to the inverse of 110%, with the appearance of a wide margin around the top and right of the page.

Note: OS X's "Preview" appears to behave the same way as printing, to save paper. I have tested this on two networked printers, and on two different computers.

Comment 1

7 years ago
This also happens in Firefox 7.0.1 and some older versions.
Component: General → Printing: Output
Product: Thunderbird → Core
QA Contact: general → printing
Version: 7 → 7 Branch

Comment 2

7 years ago
This is still not fixed in Firefox 8!

Comment 3

7 years ago
I have some trouble in Thunderbird 7 on OS 10.6.8, MacBook Core2duo.

Then, I did version up to Thunderbird 8 or downgraded to 6.0.2, there were same problem as reported.

Comment 4

7 years ago
I have same trouble in Thunderbird 7 on OS 10.6.8, MacBook Core2duo.

Then, I did version up to Thunderbird 8 or downgraded to 6.0.2, there were same problem as reported.

Comment 5

7 years ago
I'm sorry that I commented almost same content of Comment 3 and 4. 

I don't know how I delete my comment.

Comment 6

7 years ago
This bug still exists in Firefox 9.0.1!

Could someone please fix this?

Comment 7

2 years ago
Murali does this reproduce for you with Thunderbird or Firefox on Mac?
Flags: needinfo?(bmurali5128)
James, you have both FF and TB. Does this fail for you using current  beta?
http://www.mozilla.org/en-US/thunderbird/channel/
Flags: needinfo?(bmurali5128) → needinfo?(jamesrome)

Comment 9

a year ago
I don't think I see this. I printed this page from Thunderbird. see attached.
But I uncovered another issue trying to make a test message to myself of this page. TB kept encrypting it without my telling it to. I had to turn off enigmail since I could not unencrypt it.
Flags: needinfo?(jamesrome)

Comment 10

a year ago
Created attachment 8829153 [details]
test.pdf

Printing to PDF
Excellent. So mostly good news!
Use best judgement whether another bug is needed for the enigmail bits.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.