a user should be able to view history on a test case with context on test runs

RESOLVED FIXED

Status

Mozilla QA
MozTrap
--
enhancement
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: camd, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Test case version numbers aren't as meaningful without context as to where those versions were used.  When a version of a test case is shown, it should show the test cycles and runs that that version belonged to.

Additionally, when thinking of test case versions, it is synonymous with "history" of that case.  So we could present a UI that depicts the history to the user chronologically.

Ideally, supporting fields like "created on", "last updated" (perhaps also "created by" and "updated by") as well as the test cycle / test run combos for that version.
(Reporter)

Comment 1

6 years ago
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/19422601
(Reporter)

Comment 2

6 years ago
Eric Meyer changed story state to started in Pivotal Tracker
(Reporter)

Comment 3

6 years ago
Eric Meyer added a comment in Pivotal Tracker:   
   
Jonny, when you select a version, the list should disappear and the content below should update.
(Reporter)

Comment 4

6 years ago
Carl Meyer added a comment in Pivotal Tracker:   
   
jonny: note that the "more runs" link is commented in _case_form_version_list_item.html and should be moved to a JS template, inserted if there is more than one run to expand and view more than just the first
(Reporter)

Comment 5

6 years ago
Carl Meyer added a comment in Pivotal Tracker:   
   
(this testruns expansion is also needed JS here, not mentioned in erics comment)
(Reporter)

Comment 6

6 years ago
Eric Meyer added a comment in Pivotal Tracker:   
   
Should this only exist if there is more than one version available?
(Reporter)

Comment 7

6 years ago
Cameron Dawson added a comment in Pivotal Tracker:   
   
that's a good question.  But I think I lean toward showing this ui whether there is only 1 version or several.  Good for consistency and the user never has to ask, "why can't I drop this one down?"  They'll immediately see there's only 1 in the list and question answered.

Another might be something like show number of versions, and if there's only 1, don't have the drop-down.

But, you know, I think my preference is to have this drop down in all cases.
(Reporter)

Comment 8

6 years ago
Carl Meyer added a comment in Pivotal Tracker:   
   
Jonny: your update for prefixing filter inputs broke tagging test cases, as "newtag" is now "filter--newtag". Seems like some code is being shared between filters and tags on your end where it doesn't actually make sense to share it. Made a task here to fix it.
(Reporter)

Comment 9

6 years ago
Jonny Gerig Meyer added a comment in Pivotal Tracker:   
   
Carl: I fixed the tag input names. While making those changes, I decided it would make sense to use name="filter-..." for the inputs in the main filtering widget also. I pushed those changes to a new branch (master-filter-prefix); you just need to update your python to expect inputs with "filter-" prefixed names for filtering.
(Reporter)

Comment 10

6 years ago
Jonny Gerig Meyer changed story state to finished in Pivotal Tracker
(Reporter)

Comment 11

6 years ago
Carl Meyer changed story state to delivered in Pivotal Tracker
(Reporter)

Comment 12

6 years ago
Cameron Dawson changed story state to accepted in Pivotal Tracker
(Reporter)

Updated

6 years ago
Duplicate of this bug: 656342
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.