Last Comment Bug 692970 - Intermittent browser_locationBarCommand.js | Urlbar is still focused after click
: Intermittent browser_locationBarCommand.js | Urlbar is still focused after click
Status: RESOLVED FIXED
[inbound]
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: Firefox 10
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-10-07 15:34 PDT by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.03 KB, text/plain)
2011-10-07 22:44 PDT, :Margaret Leibovic
gavin.sharp: review+
Details

Description Phil Ringnalda (:philor) 2011-10-07 15:34:59 PDT
https://tbpl.mozilla.org/php/getParsedLog.php?id=6734181&tree=Firefox
Rev3 Fedora 12 mozilla-central opt test mochitest-other on 2011-10-07 14:50:41 PDT for push 35954e6f3167

TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Running test: Right click on go button
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Console message: [JavaScript Error: "redeclaration of var Cc" {file: "chrome://browser/content/content.js" line: 3}]
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Urlbar still has the value we entered
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Urlbar is still focused after click
Stack trace:
    JS frame :: chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js :: <TOP_LEVEL> :: line 76
    JS frame :: chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js :: <TOP_LEVEL> :: line 60
    JS frame :: chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js :: loadListener :: line 161
Comment 1 Treeherder Robot 2011-10-07 21:44:57 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6739855&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound pgo test mochitest-other on 2011-10-07 21:10:20

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Urlbar is still focused after click
Comment 2 :Margaret Leibovic 2011-10-07 22:44:29 PDT
Created attachment 565710 [details]
patch

Maybe the context menu is causing focus issues? I think we can just get rid of this check, since it's not really testing anything useful.
Comment 3 Treeherder Robot 2011-10-08 10:10:10 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6748009&tree=Mozilla-Inbound
Rev3 Fedora 12 mozilla-inbound pgo test mochitest-other on 2011-10-08 09:24:04

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Urlbar is still focused after click
Comment 4 Treeherder Robot 2011-10-08 12:24:15 PDT
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=6749079&tree=Mozilla-Inbound
Rev3 Fedora 12x64 mozilla-inbound pgo test mochitest-other on 2011-10-08 11:38:52

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/browser_locationBarCommand.js | Urlbar is still focused after click
Comment 5 Daniel Holbert [:dholbert] 2011-10-08 14:46:04 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/cf33518ba341
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-10-09 07:32:54 PDT
https://hg.mozilla.org/mozilla-central/rev/cf33518ba341

Note You need to log in before you can comment on or make changes to this bug.