Firefox 7 shows black stripes in images

RESOLVED WORKSFORME

Status

()

Core
ImageLib
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: mislistas.correo, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 565720 [details]
Firefox-7-black-stripe.png

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.1 (KHTML, like Gecko) Ubuntu/11.04 Chromium/13.0.782.215 Chrome/13.0.782.215 Safari/535.1

Steps to reproduce:

Open a web page with images using firefox 7.0.1 in ubuntu 11.04


Actual results:

Some images are incorrectly rendered, either with black stripes, either duplicating blocks. Attached file shows a typical case.


Expected results:

Images should be properly render.
Can you please try running firefox in the Firefox safemode (that will disable the hwardware acceleration) ?
http://support.mozilla.com/en-US/kb/Safe+Mode

Please also provide a link to your example image.
Is the black stripe always on the same place with the same image ?
(Reporter)

Comment 2

6 years ago
The problem appears in safe mode too. Sending a link to the original image is useless because the problem is random, and not related to a specific website. I used flickr because there mostly pictures and it is easier to reproduce the error. 

I can confirm that:
- The problem appears in safe mode too.
- Reloading the page doesn't fix the problem.
- The image in the cache is fine (yes, I actually searched through the chache to check that).
- Closing the tab and restoring it makes the image display properly (I checked this *after* looking in the cache).

I am attaching a screenshot of the second kind of error (duplicated blocks), it might be a different bug, but looks pretty much the same to me.
(Reporter)

Comment 3

6 years ago
Created attachment 565781 [details]
Problen appears in safe mode too
(Reporter)

Comment 4

6 years ago
Created attachment 565782 [details]
Cache file is fine

The file stored in the chache is not corrupted. Corruption seems to be only in visualization.
Can you please download a build from mozilla.org, extract it for example in /tmp and run it from there ?
Component: General → ImageLib
Product: Firefox → Core
QA Contact: general → imagelib
Can you set the environment variable MOZ_DISABLE_IMAGE_OPTIMIZE to 1, and then re-run Firefox?

I suspect X of causing this issue.
(Reporter)

Comment 7

6 years ago
The problem disappeared in Firefox 7.0.1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.