Clicking on "mail to" links takes no effect

UNCONFIRMED
Unassigned

Status

()

Firefox
General
UNCONFIRMED
7 years ago
6 years ago

People

(Reporter: Hong Xu, Unassigned)

Tracking

12 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Open a webpage and click on a "mailto" url.


Actual results:

Nothing happened. No error message, and no mail client came out.
It happens every time.


Expected results:

The mail client pops up with correct "TO line" filled.

Comment 1

7 years ago
Which Action setting do you use in Edit/Preferences/Applications/mailto?
(Reporter)

Comment 2

7 years ago
(In reply to Thomas Ahlblom from comment #1)
> Which Action setting do you use in Edit/Preferences/Applications/mailto?

It's "always ask"

Comment 3

7 years ago
FYI, Seamonkey also had an issue with mailto: links for a while. With the Oct 2 nightly build, click on the link and the mail client would pop up, but the to: address was not automatically filled in. Seamonkey behaves correctly in today's build.
(Reporter)

Updated

6 years ago
Version: 7 Branch → 12 Branch
(Reporter)

Comment 4

6 years ago
From this page: http://support.mozilla.org/en-US/kb/Changing%20the%20e-mail%20program%20used%20by%20Firefox

It says that Firefox can set default mail client by selecting "Use <Program> (default)". However, I didn't see this menu item, but I did set thunderbird as my default mail client, and it works in other programs.
You need to log in before you can comment on or make changes to this bug.