[tt-Cyrl] [Fx] New localization: Tatar, Cyrillic script

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
7 years ago
8 months ago

People

(Reporter: qdinar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tt] [tt-RU] [tt-Cyrl] [tt-Cyrl-RU])

(Reporter)

Description

7 years ago
Hello. I want to translate firefox to tatar language, I mean which is one of 2 official (governmental) languages of Republic of Tatarstan in Russian Federation. ( It is written with cyrillic alphabet, literary, it is not Crimean Tatar language/dialect, it is also called Kazan tatar language but it is also used by Mishar, Siberian, Astrakhan, Kasim tatars as literary language though their dialect differs from Kazan dialects, and there are several other dialects, native speakers of which use this literary language, and it is mutually intelligible with Bashkir (Bashkort) literary language )
language code: tt or tt_RU
(Reporter)

Comment 1

7 years ago
Link to team page on MozillaWiki: https://wiki.mozilla.org/L10n:Teams:tt
(Reporter)

Comment 2

7 years ago
Links to Tatar language, written with iqtelif latin alphabet/orthography, team / localisation registration bugs, also they are for Crimean Tatar and Turkey Tatar:
https://bugzilla.mozilla.org/show_bug.cgi?id=350637
https://bugzilla.mozilla.org/show_bug.cgi?id=400928
(Reporter)

Comment 3

7 years ago
link to iqtelif-written tatar language pack download pages:
https://addons.mozilla.org/ru/firefox/addon/id%C3%ADl-ural-tatar%C3%A7a-t%C3%ADl-paket%C3%AD/
https://addons.mozilla.org/en-US/firefox/addon/id%C3%ADl-ural-tatar%C3%A7a-t%C3%ADl-paket%C3%AD/
(made by person who posted the bugs in my previous comment, for that tt-iqtelif)
(Reporter)

Comment 4

7 years ago
my contact email is qdinar@gmail.com, my personal site is http://qdb.wp.kukmara-rayon.ru/ .
(Reporter)

Comment 5

7 years ago
Link to Crimean Tatar language pack page: https://addons.mozilla.org/en-US/firefox/addon/QIRIMTATARCA-til-destesi/ , that package is made by the person who made tt-iqtelif - Reşat SABIQ.

Comment 6

7 years ago
Redirecting this to a correct component.

Good luck.
Assignee: nobody → registration
Component: kk / Kazakh → Registration & Management
OS: Linux → All
QA Contact: kazakh.kk → registration
Hardware: x86 → All
From what I understand, Tatar can be written and spoken a few different ways, but the dialect variants all use the same writing system. Thus, we can justify using 'tt' as the language subtag. (Not that this was ever in question; it is a not a macrolanguage subtag.)

Given that Tatar can be written using the Cyrillic, Latin, and Arabic scripts, it might be best to specify that you will be using the Cyrillic script using the 'Cyrl' script subtag, especially to differentiate it from the existing language pack, which is really 'tt-Latn' or 'crh-Latn'. (According to bug 350637 comment 2, 'tt-Latn' is actually still ambiguous, because there are six different Latin variants that could be used. This, however, is easily rectifiable by registering six variant subtags with IETF Languages, per BCP 47. Of course, that is somewhat out of the scope of this bug, since we're talking about the Cyrllic script here.)

With all that being said, I have not seen justification for the use of a region tag. AFAICT, the script choice (with the exception of Latin described above) is enough to ensure mutual legibility. If you have an argument to the contrary, please do raise it.

Until then, I recommend that the language tag 'tt-Cyrl' be used.
Summary: i want to translate firefox to tatar language → [tt-Cyrl] [Fx] New localization: Tatar
Whiteboard: [tt] [tt-RU] [tt-Cyrl] [tt-Cyrl-RU]
Summary: [tt-Cyrl] [Fx] New localization: Tatar → [tt-Cyrl] [Fx] New localization: Tatar, Cyrillic script
FWIW, there is uncomplete Tatar translation of Firefox in Launchpad - https://translations.launchpad.net/ubuntu/natty/+sources/firefox/+translations
Perhaps you can use it as starting point or combine efforts with Launchpad translator in order to complete translation. Good luck.
(In reply to Alexander L. Slovesnik from comment #8)
> FWIW, there is uncomplete Tatar translation of Firefox in Launchpad -
> https://translations.launchpad.net/ubuntu/natty/+sources/firefox/
> +translations
> Perhaps you can use it as starting point or combine efforts with Launchpad
> translator in order to complete translation. Good luck.

More specifically, it's here:
https://translations.launchpad.net/ubuntu/natty/+source/firefox/+pots/firefox/tt
(Reporter)

Comment 10

7 years ago
OK.
I have not known that so much translation of Firefox is in Launchpad now. (I knew that it is possible to translate it there, but I had not liked it because of all translations submitted there become licenced with BSD. But I think now, maybe even to be shareable among open-source projects licenced under various licences like GPL, BSD, CC, Mozilla, Apache, translations should be licenced with BSD.)
About several latin scripts: if just "latn" is used nowadays, I think it should mean 1999's project. If "cyrl" is used, it should mean modern Tatar literary language, written with Cyrillic. If just "tt" is used, it also should mean modern Tatar literary language, written with Cyrillic.
I agree that "cyrl" is better to use than "RU" because language variants in other countries only differ with usage of some archaic words, but they are same language, same words are also used in literary language in older texts. And probably, Latin script is used only in several of other countries, like Turkey and Finland, in others Cyrillic is used, like in Uzbekistan, Kazakhstan, and in Turkey and Finland they probably read Cyrillic texts. Modern literary Tatar language prevail over abroad slightly archaic variants. This language could be also marked/tagged as tt-SU and tt-RT. But Tatar language is used not only in Tatarstan, not only in Russia, and Latin script can be used in Tatarstan and in Russia, nowadays it is mostly used in sites, automatically transliterated. And RT and SU are not valid countries. Because script is important in written form, even in computers, script subtag can be used.

Comment 11

7 years ago
tt should be fine; that would be the recommended form for tagging text in modern Tatar. If there's a real demand for distinction from Latin-script Tatar, I suppose tt-Cyrl is reasonable; indeed, there is no Suppress-Script defined for it in the subtag registry: http://www.iana.org/assignments/language-subtag-registry

I did initiate requests with ietf-languages for the inclusion of several script variants for Tatar, for the Latin and Arabic scripts, but those are unlikely to be needed here; if they come to be needed, I can push them through to approval at that point. Still, it would be harmful to use tt-Latn without a variant subtag to mean the 1999 Latin script, since that script never reached dominance (or even an agreed-upon name!) and there's a risk of confusion with the earlier script, which does exist online in historical documents. There is a subtag "baku1926" that can be used for the 1926-1939 Janalif: tt-baku1926 (or the redundant tt-Latn-baku1926). Having read the discussion of Latin alphabets from bug 350637, we can be glad that no rash decisions were made at that point, since a localization would have been using an undefined and unstable transliteration system.

If there are people out there with interest in getting the modern Latin scripts registered, I'd be glad to help out, but we'll need documentation of each script.

Please do remember that Crimean Tatar is a completely different language, with its own language tag, "crh".

Comment 12

7 years ago
The locale-code discussion is rather academic at this point, because the locale-selection code in gecko doesn't support script tags.

Re using BSD-licensed translations, I'm not sure that's trivial. Gerv?
(In reply to Dinar from comment #10)
> OK.
> I have not known that so much translation of Firefox is in Launchpad now. (I
> knew that it is possible to translate it there, but I had not liked it
> because of all translations submitted there become licenced with BSD. 

I'd like to understand why you think this is true. Translations are derivative works of the original, and so it's not legally possible to make a BSD-ed Firefox translation. It must be under at least one of the three licences in the tri-licence, and if Mozilla is to ship it, it must be under all three.

It is possible to take data from a BSDed source and copy it into a Firefox translation, but that's not the same thing.

Gerv

Comment 14

7 years ago
(In reply to Axel Hecht [:Pike] from comment #12)
> The locale-code discussion is rather academic at this point, because the
> locale-selection code in gecko doesn't support script tags.

Right, and although the current work on BCP 47 might change that, discussion now is quite unmotivated.

I see no reason not to use tt_RU; the Tatar-speaking populations outside of Russia are relatively small, and this translation is into the Cyrillic script, which is primarily in Russia (in no small part due to action of the Russian government). And locale names are mainly a convenience-- there's no need to see each element of them as a statement of fact about the language in question.

So best of luck to the current localization team; with this, I'll try to stay out of unnecessary academic digressions.
(Reporter)

Comment 15

7 years ago
(In reply to Gervase Markham [:gerv] from comment #13)
>...
> 
> I'd like to understand why you think this is true. Translations are
> derivative works of the original, and so it's not legally possible to make a
> BSD-ed Firefox translation. ...
>...

https://help.launchpad.net/Translations/LicensingFAQ


(In reply to Avram Lyon from comment #11)
>...
> ... Still, it would be harmful to use tt-Latn
> without a variant subtag to mean the 1999 Latin script, since that script
> never reached dominance (or even an agreed-upon name!) and there's a risk of
> confusion with the earlier script, which does exist online in historical
> documents. There is a subtag "baku1926" that can be used for the 1926-1939
> Janalif: tt-baku1926 (or the redundant tt-Latn-baku1926). ...
>...

rt1999 can be used to sign 1999 latin project, rt means republic of tatarstan.


i have tried to make sample xpi file, but it has not worked. i am on stage https://developer.mozilla.org/en/Create_a_New_Localization#Creating_a_langpack . i have made xpi from http://hg.mozilla.org/releases/mozilla-1.9.2/ and http://hg.mozilla.org/l10n-central/x-testing/ (there is no localisation folder for mozilla-1.9.2) and have tried this xpi file in firefox 3.6.17 in ubuntu 9.10, which is mozilla-1.9.2, while l10n-central is for newest firefox, may be for that it has not worked.

Comment 16

7 years ago
(In reply to Gordon P. Hemsley [:gphemsley] from comment #7)

Agree that at this point it is crucial to distinguish cyrillic variant from all latin ones (btw I've seen people in Launchpad translating in latin alphabet when the "majority" has been using cyrillic letters).

> Until then, I recommend that the language tag 'tt-Cyrl' be used.
What about 'tt_RU@cyrl' variant? Can we use '@' symbol? So it is possible to make clear that it is cyrillic but it also leaves room for creation of other country-based subvariants in the future, let's say, 'tt_FI@Latin'.

Comment 17

7 years ago
We're not using posix codes, but bcp47 ones, so neither _ nor @ are in play.

Comment 18

7 years ago
I see. Also mentioning country-name in the tag would mean splitting the tatar language community not only on the basis of script they use but also on the basis of country they live. So forget my previous post and again - a vote for 'tt-Cyrl'.
Hi Dinar,

(In reply to Dinar from comment #15)
> (In reply to Gervase Markham [:gerv] from comment #13)
> > I'd like to understand why you think this is true. Translations are
> > derivative works of the original, and so it's not legally possible to make a
> > BSD-ed Firefox translation. ...
> 
> https://help.launchpad.net/Translations/LicensingFAQ

It's taken some time, but I've now got Canonical to update this FAQ. It now says:

"We have now updated the "Translations copyright" section of the Launchpad terms of use to require that translations submitted in Launchpad licensed using the BSD licence, but also that groups of strings from one project which are a derivative work of the project are licensed under the licence of the project."

So any set of .dtd/.properties files which that web service creates for you are MPLed.

Gerv
This locale registration bug is being resolved as INCOMPLETE because it has not been updated since before the final Firefox 17esr release on 2013-11-15. It is assumed that there has not been any progress in developing the desired localization since that time.

If you feel this bug has been closed in error, please reopen it and provide a status update for your locale.

In addition, please be sure to follow the guidelines listed on the wiki for creating a new localization:

https://wiki.mozilla.org/L10n:Starting_a_localization

[Mass change filter: l10n-new-incomplete-fx17esr]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 21

5 years ago
hello
i am again trying to make translation.

this time i am working in windows 8, and will try to make this with it. another option is to use virtualbox.
links, that i have found today, that may help, if anybody else wants to translate firefox:

https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Quick_start_guide
https://bugzilla.mozilla.org/show_bug.cgi?id=693054
https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Windows_Prerequisites
https://wiki.mozilla.org/L10n:Communication

i have already installed visual studio express 2013, but only vs2011 is mentioned in the instruction.
"After the prerequisites are installed, launch one of the following batch files from the directory to which you installed MozillaBuild (c:\mozilla-build by default):
    start-msvc10.bat (VS 2010)
    start-msvc11.bat (VS 2012)"

does that work? but i am going to try that now
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 22

5 years ago
it (start-msvc11.bat) does not work, gives message:
"Microsoft Visual C++ version 11 (2012) was not found. Exiting."
(Reporter)

Comment 23

5 years ago
that is solved , there is newer version of mozilla-build
(Reporter)

Comment 24

5 years ago
hg clone https://hg.mozilla.org/mozilla-central
command from https://developer.mozilla.org/en-US/docs/Simple_Firefox_build#Get_the_source has worked very long for me and stopped without prompt and without cpu or disk usage after many hours. i will look how to download that source with archive if god wills/wants.
(Reporter)

Comment 25

5 years ago
today i have opened https://hg.mozilla.org/mozilla-central (from the comment above) and have seen links to archives and have downloaded bzip2 version and extracted it into mozilla-source (and renamed to mozilla-central, by deleting code at end of the folder's name).
then i have opened https://developer.mozilla.org/en-US/docs/Simple_Firefox_build#Get_the_source again and have seen that there is new link for unstable internet connection: https://developer.mozilla.org/en-US/docs/Developer_Guide/Source_Code/Mercurial/Bundles . it links to some files with hg extension and they are bigger then the archive i downloaded. then i have used some commands from the page.

opened
start-shell-msvc2013.bat

cd /c/mozilla-source/
hg init mozilla-central

then i have created file
mozilla-central/.hg/hgrc
with content
[paths]
default = https://hg.mozilla.org/mozilla-central/

hg pull
abort: no repository found in 'c:\mozilla-source' (.hg not found)!
cd mozilla-central
hg pull

"hg pull" is working now

(next step is hg update)

start-shell-msvc2013-x64.bat is not recommended? i will ask about that in appropriate bug report (bug 889721) , if god wants.
(Reporter)

Comment 26

5 years ago
why i did not install newest firefox the previous time - i tried to protect my files as much as i can, and i used apparmor very much, and installing new software was hard for me. also using all software from official repository looked more trustful for me. then i have stopped to try to protect my files so hardly, but i had not enough time to translate firefox then. and then after some time i have moved to windows.
(Reporter)

Comment 27

5 years ago
./mach build , after installing DXSDK_Jun10.exe , last, visible messages:

61:50.55 ssl3ecc.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_CallOnceWithArg
61:50.55
61:50.55 ssl3ext.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_CallOnceWithArg
61:50.55
61:50.55 sslsecur.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_CallOn
ceWithArg шьяюЁЄшЁютрэ т ЇєэъЎш■ _SSL_ConfigSecureServerWithCertChain
61:50.55
61:50.55 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_LoadLi
brary шьяюЁЄшЁютрэ т ЇєэъЎш■ _secmod_LoadPKCS11Module
61:50.57
61:50.57 pkix_pl_httpcertstore.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁх
фхыхээ√щ ёшьтюы _PR_LoadLibrary
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Unload
Library шьяюЁЄшЁютрэ т ЇєэъЎш■ _SECMOD_UnloadModule
61:50.57
61:50.57 pkix_pl_httpcertstore.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁх
фхыхээ√щ ёшьтюы _PR_UnloadLibrary
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_FindSy
mbol шьяюЁЄшЁютрэ т ЇєэъЎш■ _secmod_LoadPKCS11Module
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_NewLog
Module шьяюЁЄшЁютрэ т ЇєэъЎш■ _nss_InsertDeviceLog
61:50.57
61:50.57 pkix_pl_lifecycle.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхых
ээ√щ ёшьтюы _PR_NewLogModule
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_LogPri
nt шьяюЁЄшЁютрэ т ЇєэъЎш■ _NSSDBGC_CancelFunction
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Interv
alToSeconds шьяюЁЄшЁютрэ т ЇєэъЎш■ _getPrintTime
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Interv
alToMilliseconds шьяюЁЄшЁютрэ т ЇєэъЎш■ _getPrintTime
61:50.57
61:50.57 pk11load.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Interv
alToMicroseconds шьяюЁЄшЁютрэ т ЇєэъЎш■ _getPrintTime
61:50.57
61:50.57 pk11slot.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Sleep
шьяюЁЄшЁютрэ т ЇєэъЎш■ _PK11_WaitForTokenEvent
61:50.57
61:50.57 pk11util.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_Sleep
61:50.57
61:50.57 ssl3con.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_Sleep
61:50.57
61:50.57 pk11util.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_SetErr
orText шьяюЁЄшЁютрэ т ЇєэъЎш■ _SECMOD_AddNewModuleEx
61:50.57
61:50.57 certdb.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_NetAddrT
oString шьяюЁЄшЁютрэ т ЇєэъЎш■ _cert_GetDNSPatternsFromGeneralNames
61:50.57
61:50.57 certdb.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_ConvertI
Pv4AddrToIPv6 шьяюЁЄшЁютрэ т ЇєэъЎш■ _cert_VerifySubjectAltName
61:50.57
61:50.57 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Convert
IPv4AddrToIPv6 шьяюЁЄшЁютрэ т ЇєэъЎш■ _SSL_OptionGet
61:50.57
61:50.57 certdb.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_htonl шь
яюЁЄшЁютрэ т ЇєэъЎш■ _cert_VerifySubjectAltName
61:50.57
61:50.57 polcyxtn.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_sprint
f_append шьяюЁЄшЁютрэ т ЇєэъЎш■ _stringFromUserNotice
61:50.57
61:50.57 pkix_pl_string.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√
щ ёшьтюы _PR_sprintf_append
61:50.57
61:50.57 error.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_NewThread
PrivateIndex шьяюЁЄшЁютрэ т ЇєэъЎш■ _error_once_function
61:50.57
61:50.57 error.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_SetThread
Private шьяюЁЄшЁютрэ т ЇєэъЎш■ _error_get_my_stack
61:50.57
61:50.57 error.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetThread
Private шьяюЁЄшЁютрэ т ЇєэъЎш■ _error_get_my_stack
61:50.57
61:50.57 pkix_pl_rwlock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
NewRWLock шьяюЁЄшЁютрэ т ЇєэъЎш■ _PKIX_PL_RWLock_Create
61:50.57
61:50.57 sslnonce.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_NewRWLock
61:50.57
61:50.57 pkix_pl_rwlock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
DestroyRWLock шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_RWLock_Destroy
61:50.57
61:50.57 sslnonce.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_DestroyRWLock
61:50.57
61:50.57 pkix_pl_rwlock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
RWLock_Rlock шьяюЁЄшЁютрэ т ЇєэъЎш■ _PKIX_PL_AcquireReaderLock
61:50.57
61:50.57 ssl3con.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_RWLock_Rlock
61:50.57
61:50.57 pkix_pl_rwlock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
RWLock_Wlock шьяюЁЄшЁютрэ т ЇєэъЎш■ _PKIX_PL_AcquireWriterLock
61:50.59
61:50.59 sslnonce.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_RWLock_Wlock
61:50.59
61:50.59 pkix_pl_rwlock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
RWLock_Unlock шьяюЁЄшЁютрэ т ЇєэъЎш■ _PKIX_PL_ReleaseReaderLock
61:50.59
61:50.59 ssl3con.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_RWLock_Unlock
61:50.59
61:50.59 sslnonce.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_RWLock_Unlock
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_Open шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_CollectionCertStoreContext_CreateCRL
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_Read шьяюЁЄшЁютрэ т ЇєэъЎш■ _SECU_FileToItem
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_GetOpenFileInfo шьяюЁЄшЁютрэ т ЇєэъЎш■ _SECU_FileToItem
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_OpenDir шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_CollectionCertStoreContext_Populat
eCRL
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_ReadDir шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_CollectionCertStoreContext_Populat
eCRL
61:50.59
61:50.59 pkix_pl_colcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтю
ы _PR_CloseDir шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_CollectionCertStoreContext_Popula
teCRL
61:50.59
61:50.59 pkix_pl_httpcertstore.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьт
юы _PR_FindFunctionSymbol шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_getDecodeFunction
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
ConnectContinue шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_ConnectContinue
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
Accept шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_Accept
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
Bind шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_CreateServer
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
Listen шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_Listen
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
Shutdown шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_Shutdown
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
Send шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_Send
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
ErrorToString шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_CreateServer
61:50.59
61:50.59 pkix_pl_socket.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_
htons шьяюЁЄшЁютрэ т ЇєэъЎш■ _pkix_pl_Socket_CreateByHostAndPort
61:50.59
61:50.59 dtlscon.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Millise
condsToInterval шьяюЁЄшЁютрэ т ЇєэъЎш■ _DTLS_GetHandshakeTimeout
61:50.60
61:50.60 ssldef.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_PopIOLay
er шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_DefClose
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_MemMap
шьяюЁЄшЁютрэ т ЇєэъЎш■ _InitCache
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_MemUnma
p шьяюЁЄшЁютрэ т ЇєэъЎш■ _CloseCache
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_CloseFi
leMap шьяюЁЄшЁютрэ т ЇєэъЎш■ _CloseCache
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_OpenAno
nFileMap шьяюЁЄшЁютрэ т ЇєэъЎш■ _InitCache
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_ExportF
ileMapAsString шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_ConfigMPServerSIDCacheWithOpt
61:50.60
61:50.60 sslsnce.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_ImportF
ileMapFromString шьяюЁЄшЁютрэ т ЇєэъЎш■ _SSL_InheritMPServerSIDCacheInstance
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetUniq
ueIdentity шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_InitIOLayer
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetIden
titiesLayer шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_FindSocket
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetDefa
ultIOMethods шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_SetupIOMethods
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_CreateI
OLayerStub шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_PushIOLayer
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_PushIOL
ayer шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_PushIOLayer
61:50.60
61:50.60 sslsock.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetSock
etOption шьяюЁЄшЁютрэ т ЇєэъЎш■ _ssl_FdIsBlocking
61:50.60
61:50.60 plarena.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_Ceiling
Log2 шьяюЁЄшЁютрэ т ЇєэъЎш■ _PL_InitArenaPool
61:50.60
61:50.60 plhash.obj : warning LNK4049: шьяюЁЄшЁютрэ ыюъры№эю юяЁхфхыхээ√щ ёшьтюы
 _PR_CeilingLog2
61:50.60
61:50.60 plerror.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetSpec
ialFD шьяюЁЄшЁютрэ т ЇєэъЎш■ _PL_PrintError
61:50.60
61:50.60 plerror.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_fprintf
 шьяюЁЄшЁютрэ т ЇєэъЎш■ _PL_FPrintError
61:50.60
61:50.60 plerror.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_GetOSEr
ror шьяюЁЄшЁютрэ т ЇєэъЎш■ _PL_FPrintError
61:50.60
61:50.60 plerror.obj : warning LNK4217: ыюъры№эю юяЁхфхыхээ√щ ёшьтюы _PR_ErrorTo
Name шьяюЁЄшЁютрэ т ЇєэъЎш■ _PL_FPrintError
61:50.60
61:56.37 mozmake.EXE[6]: *** No rule to make target 'c:/mozilla-source/mozilla-c
entral/obj-i686-pc-mingw32/dist/lib/nspr4.lib', needed by 'c:/mozilla-source/moz
illa-central/obj-i686-pc-mingw32/security/nss/cmd/shlibsign/shlibsign.exe'.  Sto
p.
61:56.37 mozmake.EXE[6]: *** Waiting for unfinished jobs....
61:56.51 mozmake.EXE[6]: *** No rule to make target 'c:/mozilla-source/mozilla-c
entral/obj-i686-pc-mingw32/dist/lib/nspr4.lib', needed by 'c:/mozilla-source/moz
illa-central/obj-i686-pc-mingw32/security/nss/cmd/pk12util/pk12util.exe'.  Stop.

61:56.51 mozmake.EXE[6]: *** Waiting for unfinished jobs....
61:56.51 shlibsign.c
61:57.01 certext.c
61:57.05 pk12util.c
61:57.10 Warning: C4018 in c:\mozilla-source\mozilla-central\security\nss\cmd\sh
libsign\shlibsign.c: <: несоответствие типов со знаком и без знака
61:57.10 c:/mozilla-source/mozilla-central/security/nss/cmd/shlibsign/shlibsign.
c(908) : warning C4018: <: несоответствие типов со знаком и без знака
61:57.26 Makefile:474: recipe for target 'libs-nss/cmd/shlibsign' failed
61:57.26 mozmake.EXE[5]: *** [libs-nss/cmd/shlibsign] Error 2
61:57.26 mozmake.EXE[5]: *** Waiting for unfinished jobs....
61:57.68 certutil.c
61:58.51 keystuff.c
61:58.62 Makefile:474: recipe for target 'libs-nss/cmd/pk12util' failed
61:58.62 mozmake.EXE[5]: *** [libs-nss/cmd/pk12util] Error 2
61:59.12 Оптимизирующий компилятор Microsoft (R) C/C++ версии 18.00.21005.1 для
x86
61:59.12 (C) Корпорация Майкрософт (Microsoft Corporation).  Все права защищены.

61:59.12
61:59.15 Microsoft (R) Incremental Linker Version 12.00.21005.1
61:59.15 Copyright (C) Microsoft Corporation.  All rights reserved.
61:59.15
61:59.15 /out:c:/mozilla-source/mozilla-central/obj-i686-pc-mingw32/security/nss
/cmd/certutil/certutil.exe
61:59.15 -DEBUG
61:59.15 -OPT:REF
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\sectool.
lib
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\nssutil3
.lib
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\smime3.l
ib
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\ssl3.lib

61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\nss3.lib

61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\plc4.lib

61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\plds4.li
b
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\lib\nspr4.li
b
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\security\nss\cmd\
certutil\certext.obj
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\security\nss\cmd\
certutil\certutil.obj
61:59.15 c:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\security\nss\cmd\
certutil\keystuff.obj
62:00.18 c:/mozilla-source/mozilla-central/config/recurse.mk:95: recipe for targ
et 'security/build/libs' failed
62:00.18 mozmake.EXE[4]: *** [security/build/libs] Error 2
62:00.18 c:/mozilla-source/mozilla-central/config/recurse.mk:39: recipe for targ
et 'libs' failed
62:00.18 mozmake.EXE[3]: *** [libs] Error 2
62:00.18 c:/mozilla-source/mozilla-central/config/rules.mk:592: recipe for targe
t 'default' failed
62:00.18 mozmake.EXE[2]: *** [default] Error 2
62:00.30 c:/mozilla-source/mozilla-central/client.mk:398: recipe for target 'rea
lbuild' failed
62:00.30 mozmake.EXE[1]: *** [realbuild] Error 2
62:00.52 client.mk:185: recipe for target 'build' failed
62:00.52 mozmake.EXE: *** [build] Error 2
Single process terminated successfully
62:00.66 657 compiler warnings present.
2

"Ё- а@IDEA-PC /c/mozilla-source/mozilla-central
$
(Reporter)

Comment 28

5 years ago
my laptop has only 2gb of ram, 3 is required by "Windows build prerequisites"
(Reporter)

Comment 29

5 years ago
i have added 2 gb of ram , asked in chat (#firefox), a person said it is because of low memory, i have tried again, hg update - nothing, then hg pull then hg update - it is fast. then ./mach build - but some errors, then there was a command shown, i used it,  ./mach .... , it was fast, some errors ,then again tried ./mach build and  it have worked. but, when i looked at ram usage this time and previous time, processes related to this used it very small, several % , while firefox is using near 30%.
i have started it, (by path shown by compiler output), and it opens just a new window to firefox, then i have started/runned it with my additional profile ("fresh"):
cd C:\mozilla-source\mozilla-central\obj-i686-pc-mingw32\dist\bin
firefox.exe -no-remote -p fresh
and it works, i see a new design.
(Reporter)

Comment 30

5 years ago
not important, just fixing the last comment to not be a lie:
also i (had) opened firefox.exe -no-remote (while firefox was running) , it do not work, says that it is already running... (but you can close firefox and run the new version and it should work, but making a new profile is better, for that use firefox.exe -p )
(Reporter)

Comment 31

4 years ago
previous time i tried to translate , i read an instruction , easy way to download a folder for xpi file , then to translate phrases in with text editor, then make xpi from it (that is almost only zipping) , but this time i have(had) not found it.
(Reporter)

Comment 32

4 years ago
tatar is installed in pootle service : http://mozilla.locamotion.org/tt_RU/

and lang code is tt_RU for now . i think it is also correct , good , because the tatar cyrillic has tight relation to russian language and also its official usage in tatarstan is supported , enforced by law of russia .
(In reply to Dinar from comment #32)
> tatar is installed in pootle service : http://mozilla.locamotion.org/tt_RU/
> 
> and lang code is tt_RU for now . i think it is also correct , good , because
> the tatar cyrillic has tight relation to russian language and also its
> official usage in tatarstan is supported , enforced by law of russia .

I disagree with this decision, especially because once a language code is chosen, it becomes exceedingly hard to change it in the future.

I continue to recommend the use of 'tt-Cyrl' for this locale.
(Reporter)

Comment 34

4 years ago
"I disagree with this decision ......"

it is also according to standart , script subtag should be used earlier than region subtag. ( https://en.wikipedia.org/wiki/IETF_language_tag )

that was not my decision, just i could not answer quickly what code to use , started to read this bug's comments, and at that time dwayne bailey installed it with tt_RU temporarily.

i will ask him to change it, in #pootle in freenode.
(Reporter)

Comment 35

4 years ago
see what Axel said in comment 12 :
"The locale-code discussion is rather academic at this point, because the locale-selection code in gecko doesn't support script tags."


cyrl etc do not work in firefox.
I'm going to mark this bug as incomplete. Locale is available on Pootle, but there's no activity.
https://mozilla.locamotion.org/tt_RU/

We can re-evaluate the situation in the future, provided that the translation effort is sustained consistently over time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 37

8 months ago
(In reply to Dinar from comment #15)
> (In reply to Avram Lyon from comment #11)
> >...
> > ... Still, it would be harmful to use tt-Latn
> > without a variant subtag to mean the 1999 Latin script, since that script
> > never reached dominance (or even an agreed-upon name!) and there's a risk of
> > confusion with the earlier script, which does exist online in historical
> > documents. There is a subtag "baku1926" that can be used for the 1926-1939
> > Janalif: tt-baku1926 (or the redundant tt-Latn-baku1926). ...
> >...
> 
> rt1999 can be used to sign 1999 latin project, rt means republic of
> tatarstan.

1999 was wrong. resolution was accepted by cabinet of ministers in 2000. this is not request to register, but only about how it should be. seems it should be tt-latn-2000 . also there were 2 resolutions in 2000, #618 and #882, i think the last one should be used. there were suggestion for changes from academy of sciences of tatarstan in 2001, but i think it was not accepted by cabinet of ministers, because #38 of 2013 canceled resolution #882 of 2000.
(Reporter)

Comment 38

8 months ago
i have requested to activate project in https://pontoon.mozilla.org/ , but maybe it should not be, because translation was not active, as i know. i have not looked what is happening in https://mozilla.locamotion.org/tt_RU/ for long time. that site is deactivated now, projects are moved to pontoon.
You need to log in before you can comment on or make changes to this bug.