Seamonkey through RDP Session - after ScreenSaver(blanking) no window refresh

RESOLVED DUPLICATE of bug 594407

Status

RESOLVED DUPLICATE of bug 594407
7 years ago
7 years ago

People

(Reporter: t50, Unassigned)

Tracking

SeaMonkey 2.3 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build ID: 20100401080539

Steps to reproduce:

I have used Seamokey 2.0.11 and everything was ok.I have not changed/installed anything on local or remote RDP both XP machines (auto update disabled). After upgrade to 2.3.3 and later to 2.4.1 problem still persist and I want to report it. What's wrong:
1.I connect to my remote PC over MSRDP Client. There is Seamonkey window Messenger Client opened on remote machine .
2.I leave the RDP session to time screensaver is activated on remote session, not on local machine. Actually only blank screen is activated due to no mouse/keyboard reaction on remote desktop. I use default Windows logo screensaver there.
3.I move mouse to "wake up" - every app window can be refreshed/painted if You select minimize/maximize appication on task bar except Mozilla. After You select Mozilla the window has only main thin frame and System menu (Close(X)Minimize(_) buttons and transparent all of the window content )You see desktop or other windows through it. If You click "Show Desktop" and thereafter Mozilla - still only frame visible. All other applications I have opened don't have such problem.
4.You have to close Mozilla by X and open it again to use and see Mozilla application window content normally. 
5.It happens after screensaver on remote XP SP3 machine.
6.The last correct version was 2.0.11 which worked fine without disappearing window content when visible over RDP session.


Actual results:

The window content dissaperes after wake up from screensaver on remote session (MSRDP).


Expected results:

Refreshed window content after clicking of application minimize/maximize.
this looks like a dupe of bug bug 594407 .
Please select help/restart with addons disabled and test again.
This disables the hardware acceleration and that should "fix" the issue
(Reporter)

Comment 2

7 years ago
Maybe, but it is serius bug with invalidate client rectangle which is completely absent in firefox and all other apps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 594407
You need to log in before you can comment on or make changes to this bug.