Closed Bug 693086 Opened 8 years ago Closed 8 years ago

Very frequent "Something went wrong" alerts

Categories

(Firefox for Android Graveyard :: General, defect, major)

ARM
Android
defect
Not set
major

Tracking

(firefox10-)

VERIFIED FIXED
Firefox 10
Tracking Status
firefox10 - ---

People

(Reporter: hsivonen, Unassigned)

References

()

Details

Starting with the 20111008030946 build (http://hg.mozilla.org/mozilla-central/rev/6c780dcb4b99), Nightly on Android very frequently shows an alert that says: "Sorry! Something went wrong while displaying a web page. [Close tab] [Reload tab]" ("web" uncapitalized in the actual UI string.)

E.g. browsing to Slashdot and opening a couple of links to news sites should be enough to trigger this. One page that triggers this is http://www.infoworld.com/d/application-development/oracles-ambitious-plan-client-side-java-175241 but it happened to me on many other pages as well.
These are content process crashes. Can you list some relevant crash reports from about:crashes?
Related to bug 693103?

I'm seeing these crashes too, but there is no send crash report option in the dialog, nor do I get crash reports added in about:crashes.
This is on the EEE Transformer.
I'm seeing it too and it's annoying the hell out of me. I'm going to see if I can bisect this.
I'm seeing this on my transformer today too. I can trigger content process crashes by "scrubbing" scrolling up and down on a page. No crash reports. :(
No crash reports for me either after getting the "something went wrong..." dialog as least 20 times since yesterday.
Forgot to add that after clicking reload, more times than none the page reloaded but I couldn't get the UI to show or the page to scroll.
I have seen this twice today on Google News (classic), but I can't easily make it happen again. For anyone else seeing this issue, what pages are you loading? Does it happen during the load? Does it happen while panning or tapping links?

Let's try to get more data
I can reproduce consistently by going to planet.mozilla.org and scrolling the page up and down a bunch in half page increments. I do that for about 30 seconds and it crashes.
(In reply to Josh Matthews [:jdm] from comment #1)
> These are content process crashes. Can you list some relevant crash reports
> from about:crashes?

There's nothing there.

(In reply to Asa Dotzler [:asa] from comment #8)
> I can reproduce consistently by going to planet.mozilla.org and scrolling
> the page up and down a bunch in half page increments. I do that for about 30
> seconds and it crashes.

I scrolled and scrolled planet without a crash. Then I multitouch zoomed and it the content process crashed. Next I zoomed and zoomed without a crash. Then I scrolled and it crashed.

Nominating as tracking. I think we can't ship Firefox 10 for Android with this bug.
I just got at least 5 crashes trying to read this page.  Load page, double tap to zoom and resize the fonts, a bunch of short scrolls down the page.  After reloading a few times the page just locks up and you can not scroll or do anything (even pan to see to get the UI to show) except go back a page using the back button.
(In reply to Kurt Schultz (supernova_00) from comment #10)
> I just got at least 5 crashes trying to read this page.
https://github.com/CyanogenMod/android_vendor_cyanogen/blob/gingerbread/CHANGELOG.mkdn

and now that I've been at work for 12 hours I can tell you that the content crash happened on every single page that I went to today.  This bug makes Fennec completely useless to access the internet and I'm going to have to switch until something is backed out to fix this issue because I couldn't complete reading one single page without the content crash and resulting useless locked browser.
Bisection result:

The first bad revision is:
changeset:   78246:703df62e855b
user:        Oleg Romashin <romaxa@gmail.com>
date:        Sun Oct 02 17:19:32 2011 -0400
summary:     Bug 690469 - ShadowThebesLayer Init/Swap API rework. r=cjones
I confirm backing out 703df62e855b fixes the issue in m-c.
Can anyone get this in a debugger? It'd be nice to know why this doesn't trip crash reporting.
fixed by backout https://hg.mozilla.org/mozilla-central/rev/524a6bb8744b
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
(In reply to Ted Mielczarek [:ted, :luser] from comment #14)
> Can anyone get this in a debugger? It'd be nice to know why this doesn't
> trip crash reporting.

yes, that would be very good to know. But let's track that in a different bug, I've filed bug 693309 for it.
The backout was backed out until we can figure out which of several patches broke Android tests:
https://hg.mozilla.org/mozilla-central/rev/bcf12565b95b
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The core issue might be fixed by bug 693282.
Status: REOPENED → NEW
Sounds like problem caused by bug 693282, which makes ShadowThebes back buffers leaking... 
I've created try build with that problem fixed:
https://tbpl.mozilla.org/?tree=Try&rev=5afde775820a
I confirm the fix in bug 693282 makes the problem go away.
Re-landed the backout (with a clobber to prevent the test failures):
https://hg.mozilla.org/mozilla-central/rev/b0e79255fa97
Status: NEW → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 10
Blocks: 690469
Verified fixed on build: Mozilla /5.0 (Android;Linux armv7l;rv:10.0a1) Gecko/20111104 Firefox/10.0a1 Fennec/10.0a1
Device: Samsung Galaxy S II (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.