"reference to undefined name 'ajaxrss'" on /en

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: Janet Swisher, Assigned: oremj)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 565754 [details]
screenshot showing the problem

On the root page of the English docs, this error appears:

reference to undefined name 'ajaxrss' Exception of type 'MindTouch.Deki.Script.Runtime.DekiScriptUndefinedNameException' was thrown. 

Callstack:
    at en
    at Template:mainpagetabbox
    at en/Web-tab

MindTouch.Deki.Script.Runtime.DekiScriptUndefinedNameException: reference to undefined name 'ajaxrss' Exception of type 'MindTouch.Deki.Script.Runtime.DekiScriptUndefinedNameException' was thrown.
  at MindTouch.Deki.Script.Compiler.DekiScriptExpressionEvaluation.Visit (MindTouch.Deki.Script.Expr.DekiScriptVar expr, DekiScriptExpressionEvaluationState state) [0x00000] in <filename unknown>:0 
  at MindTouch.Deki.Script.Expr.DekiScriptVar.VisitWith[DekiScriptExpressionEvaluationState,Range] (IDekiScriptExpressionVisitor`2 visitor, DekiScriptExpressionEvaluationState state) [0x00000] in <filename unknown>:0 
  at MindTouch.Deki.Script.Compiler.DekiScriptExpressionEvaluation.Visit (MindTouch.Deki.Script.Expr.DekiScriptCall expr, DekiScriptExpressionEvaluationState state) [0x00000] in <filename unknown>:0 
  at MindTouch.Deki.Script.Expr.DekiScriptCall.VisitWith[DekiScriptExpressionEvaluationState,Range] (IDekiScriptExpressionVisitor`2 visitor, DekiScriptExpressionEvaluationState state) [0x00000] in <filename unknown>:0 
  at MindTouch.Deki.Script.Compiler.DekiScriptExpressionEvaluation.Visit (MindTouch.Deki.Script.Expr.DekiScriptReturnScope expr, DekiScriptExpressionEvaluationState state) [0x00000] in <filename unknown>:0 

This is caused by the following template:

{{ajaxrss{ feed: 'https://developer.mozilla.org/devnews/?feed=atom' , short: true, max: '5', charset: 'UTF-8' }}}

This may be related to earlier bugs caused by failure to load Deki extensions, such as #683362.
The setting for this got lost and I forgot to fix it since the page where we use this extension isn't frequently seen anymore (it gets bypassed by the Django front-end by default now). I've fixed it now, although the fix may not take effect on all servers until after a restart, so I'm sending this bug to IT for a server restart.
Assignee: nobody → server-ops
Component: Deki Infrastructure → Server Operations
Product: Mozilla Developer Network → mozilla.org
QA Contact: infrastructure → cshields
Version: Deki → other
(Assignee)

Updated

6 years ago
Assignee: server-ops → jeremy.orem+bugs
(Assignee)

Updated

6 years ago
Component: Server Operations → Server Operations: Web Operations
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.