Closed Bug 693107 Opened 10 years ago Closed 10 years ago

Layout issue at gmail reply button context menu

Categories

(Tech Evangelism Graveyard :: English US, defect)

defect
Not set
normal

Tracking

(firefox10- unaffected)

RESOLVED FIXED
Tracking Status
firefox10 - unaffected

People

(Reporter: gustavokopper, Assigned: ehsan.akhgari)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image gmail_issue.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111008 Firefox/10.0a1
Build ID: 20111008154359

Steps to reproduce:

I opened Gmail, than i opened an e-mail and i clicked on the arrow beside the button to answer.


Actual results:

The layer has been built wrong. A little to far away.


Expected results:

The layer has to be built near reply button.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Regressed between 2011-09-18 and 2011-10-06.
Summary: Layout issue at gmail reply button → Layout issue at gmail reply button context menu
Regression window(m-c hourly),
Works:
http://hg.mozilla.org/mozilla-central/rev/60e86b847759
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929122038
Fails:
http://hg.mozilla.org/mozilla-central/rev/af3668a89015
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20110929 Firefox/10.0a1 ID:20110929141938
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=60e86b847759&tochange=af3668a89015
Thanks Alice!
Going to guess that this is caused by bug 10290.
Blocks: 691591
(In reply to Timothy Nikkel (:tn) from comment #4)
> Going to guess that this is caused by bug 10290.

you mean bug 10209. If so, it's a Tech Evangelism bug.
... and should be reported to Google
I bisected the range, and here's the first bad revision:

changeset:   77858:34f184d2a6f8
user:        Ehsan Akhgari <ehsan@mozilla.com>
date:        Mon May 09 20:36:10 2011 -0400
summary:     Bug 10209 - Part 5: Allow table elements to act as absolute positioning containers; r=roc

http://hg.mozilla.org/mozilla-central/rev/34f184d2a6f8
Assignee: nobody → ehsan
The context menu is a div with this class: "b7 J-M".  The stylesheet sets position: absolute for ".b7".

Up in the parent chain, there is a table element (which is the message display area) with class "Bs nH iY", and the stylesheet sets position: relative for ".Bs".  So, the table is now acting as the absolute positioning block.

7 levels up the parent hierarchy, there is a div element with class: "k".  The stylesheet sets position: relative for ".k", so this is the div which used to act as the absolute positioning block before bug 10209 was fixed.  This div includes the message display area together with the global action buttons (such as Archive, Spam, Delete, etc.).  The difference between the top position of this div and the table element is equal to the incorrect height offset under which the context menu div shows up.

This is definitely a bug in Gmail.  I will contact Google about this issue to see if I can find somebody on the Gmail team.
Component: Layout → English US
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Version: Trunk → unspecified
(In reply to Ehsan Akhgari [:ehsan] from comment #8)
> This is definitely a bug in Gmail.  I will contact Google about this issue
> to see if I can find somebody on the Gmail team.

Hi Ehsan, have you been able to get in touch with Google? This appears to still reproduce for me on Beta 10.
(In reply to Alex Keybl [:akeybl] from comment #9)
> (In reply to Ehsan Akhgari [:ehsan] from comment #8)
> > This is definitely a bug in Gmail.  I will contact Google about this issue
> > to see if I can find somebody on the Gmail team.
> 
> Hi Ehsan, have you been able to get in touch with Google? This appears to
> still reproduce for me on Beta 10.

Yes, I got in touch with them.  Seems like they've fixed the bug, even though they never got back to me.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.