If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Virtually all channels are blank on TV Guide.com with nightly builds

RESOLVED DUPLICATE of bug 693311

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 693311
6 years ago
6 years ago

People

(Reporter: Larry Snow, Unassigned)

Tracking

({regression})

10 Branch
x86
Windows XP
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox10-)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 565805 [details]
Clipboard01.jpg

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0a1) Gecko/20111009 Firefox/10.0a1 Firefox/10.0a1
Build ID: 20111009031012

Steps to reproduce:

Go to TVGuide.com with nightly builds from 11/8 or 11/9. 


Actual results:

All shows for channels above 35 show nothing.


Expected results:

All shows should show up.  It works with the nightly build of 11/7 and here is the strange part: it works with all builds if you run them in safe mode.  But this makes no sense to me because all these builds that I tested it with are pristine profiles--nothing to disable.

This appears to different from 585726 because the result is different looking and it works in safe mode even though safe mode shouldn't really change anything.

Comment 1

6 years ago
Confirmed on 
http://hg.mozilla.org/mozilla-central/rev/b4da2d439cbc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111009 Firefox/10.0a1 ID:20111009031012

It works if I set javascript.options.methodjit.content=false.


Regression window(m-c hourly)
Works:
http://hg.mozilla.org/mozilla-central/rev/c3a50afc2243
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111007031227
Fails:
http://hg.mozilla.org/mozilla-central/rev/bd1411e362fb
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111007 Firefox/10.0a1 ID:20111007034151



Regression window(m-i hourly)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/312306f72fa3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1 ID:20111006102902
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/5e51a2a6ef4f
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111006 Firefox/10.0a1 ID:20111006105806
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=312306f72fa3&tochange=5e51a2a6ef4f
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general

Updated

6 years ago

Comment 2

6 years ago
The only sensible choice from that list is bug 690974.
Blocks: 690974
(Reporter)

Comment 3

6 years ago
Yep, I get what Alice gets--if you set javascript.options.methodjit.content=false it works.  Figured it had to be a javascript problem because Ray said the jit's get disabled in safemode.
This is probably the same problem as bug 693311.
tracking-firefox10: --- → +
Depends on: 693311
Works with the latest nightly, so this was indeed bug 693311.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693311

Updated

6 years ago
tracking-firefox10: + → -
You need to log in before you can comment on or make changes to this bug.