Find in page highlighted result invisible for sites with fixed-position header/footer

RESOLVED DUPLICATE of bug 622801

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 622801
6 years ago
6 years ago

People

(Reporter: Thomas Rutter, Unassigned)

Tracking

7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Find in page is increasingly broken for popular sites (such as Google Plus, Facebook or Twitter) which have fixed-position headers or footers.

To reproduce: On a page containing a fixed-position header or footer, conduct a Find in page search (e.g. Ctrl+F) for a term that is higher up the page or (for pages with a footer) lower down than the current visible viewport.

Eg. In Google+, scroll downwards in the page, and then open the find toolbar and do a search for a term earlier in the page.


Actual results:

The browser may scroll within the page while you type, but there is no indication that a match is found and there is no highlighted section visible on-screen.  This is because the highlighted text is obscured by a fixed-position header or footer.


Expected results:

The browser is scrolled enough that the highlighted portion comes into view, or is centered within the page giving it the best chance of being visible.

Google Chrome scrolls so that the found text is centered in the page, eliminating this problem virtually everywhere.

IE8+ seems to scroll so that the found text is shown with enough space above/below it to accommodate the fixed-position element.  This seems to work fine with the common sites (Google Plus, Twitter, Facebook etc).
(Reporter)

Updated

6 years ago
Component: General → Search
(Reporter)

Updated

6 years ago
Component: Search → General

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 622801
You need to log in before you can comment on or make changes to this bug.