Closed Bug 69329 Opened 21 years ago Closed 18 years ago

Use plain text editor for HTML source view

Categories

(SeaMonkey :: Composer, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Future

People

(Reporter: neil, Assigned: neil)

References

(Depends on 1 open bug, Blocks 4 open bugs)

Details

Attachments

(1 file, 4 obsolete files)

Currently the HTML source view uses an XUL text field.
There's no way to tell if the field has been modified.
This issue could be resolved if the plain text editor was used.
Additionally you could then implement Find and Replace or Print Source.
That's bug 35268 : [RFE] Edit Source using External Editor

*** This bug has been marked as a duplicate of 35268 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
No, I'm referring to the Plaintext Editor on Composer's Debug menu.
this sounds like a duplicate... reassign to cmanske since he may know where that 
bug is...I haven't been able to find it
maybe Simon knows of the bug?
Assignee: beppe → cmanske
Status: REOPENED → NEW
OS: Windows 95 → All
Hardware: PC → All
Status: NEW → ASSIGNED
Target Milestone: --- → Future
I have 3 or 4 bugs about HTML source which will all be fixed when we have
a better plain text editor solution. I don't see any other bug about the
central issue -- using the full plain text editor.
So we can keep this as the tracking bug.
spam composer change
Component: Editor: Core → Editor: Composer
Blocks: 112441
is this kinda related to bug 8589 ?
bug 8589 is somewhat related, in that allowing an external app is one solution,
but we'd prefer to have our own HTML source editor as well.
*** Bug 134722 has been marked as a duplicate of this bug. ***
Blocks: 82239
Blocks: 141338
Blocks: 130615
Depends on: 66296
Summary: [RFE] Use plain text editor for HTML source view → Use plain text editor for HTML source view
Attached patch The story so far :-) (obsolete) — Splinter Review

*** This bug has been marked as a duplicate of 8589 ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago19 years ago
Resolution: --- → DUPLICATE
Doesn't anybody read comment 2 around here?
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
No longer blocks: 130615
Attached patch Mostly correct (obsolete) — Splinter Review
Attached patch Fixed typo (obsolete) — Splinter Review
Attachment #107017 - Attachment is obsolete: true
Attachment #119325 - Attachment is obsolete: true
Comment on attachment 119327 [details] [diff] [review]
Fixed typo

Can you change this comment to include "<editor>"?
+    // Initialize our "textarea"


This line concerns me, did we lose the optimization for not needing to rebuild
the source/dom tree?  Apparently not, but can we get rid of this altogether? 
Is there some other state we need to keep this global around for or can we
always just ask the editor?
+    gHTMLSourceChanged = true; // suppress notifications


remove this line:
+    //gSourceTextEditor.beginningOfDocument();
Attachment #119327 - Attachment is obsolete: true
Comment on attachment 119672 [details] [diff] [review]
Optimized gHTMLSourceChanged away

r=brade
please test undo/redo scenarios such as undo/redo in html source view and then
switch to normal and do a few things and undo/redo back through html source
view
Attachment #119672 - Flags: review+
Attachment #119672 - Attachment is obsolete: true
Attachment #121892 - Flags: superreview?(kin)
Attachment #121892 - Flags: review?(brade)
Comment on attachment 121892 [details] [diff] [review]
Implement Find in HTML source

r=brade
Attachment #121892 - Flags: review?(brade) → review+
-->Neil since he has the patch
Assignee: cmanske → neil
Status: REOPENED → NEW
This is fabulous work! Thank you, Neil!
I have played with this patch for a few hours and haven't found any problems.
This is a feature that has been widely requested and opens a whole area of 
improvements to the HTML Source editor. I've added a few other bugs that could
be fixed once this work is checked in.
I highly recommend this for 1.4final.
 
Blocks: 41308, 47040, 58730
Flags: blocking1.4?
Flags: blocking1.4? → blocking1.4-
Attachment #121892 - Flags: superreview?(kin) → superreview?(sfraser)
Comment on attachment 121892 [details] [diff] [review]
Implement Find in HTML source

/me plays sr hokey-cokey
Attachment #121892 - Flags: superreview?(sfraser) → superreview?(alecf)
Comment on attachment 121892 [details] [diff] [review]
Implement Find in HTML source

sr=alecf
I don't see "var" declarations for all those global variables - are they
declared elsewhere? Have you tried this with strict javascript mode on to see
if you get warnings?
(still get the sr, just want to make sure all is good)
Attachment #121892 - Flags: superreview?(alecf) → superreview+
Fix checked in. Yay!
Status: NEW → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
QA Contact: sujay → sairuh
*** Bug 76374 has been marked as a duplicate of this bug. ***
I can't search the Source-pane with v1.4.1. Can anyone verify this before I open
a new bug? 

Thanks,

Prog.

PS.
The 1.4.1 Release Candidate can be found here:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.4.1/
Please see Bug 220212 for a minor problem.  FIND doesn't find a string that is
word wrapped at the end of a line in HTML SOURCE view.
*** Bug 218468 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
when using "view page source" from the new "server not found" page, it just displayes the "server not found" page in the page source - not its html.  FF 1.5 Beta 2.

Try this:
1. Go to http://www.glori.bschool.unc.edu/
2. View page source

You will see "server not found" as a page, not its html
You need to log in before you can comment on or make changes to this bug.