Closed Bug 693338 Opened 8 years ago Closed 8 years ago

Typing on dartlang.org doesn't work in Fennec

Categories

(Firefox for Android :: Keyboards and IME, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 746769
Tracking Status
blocking-fennec1.0 --- soft

People

(Reporter: ehsan, Unassigned)

References

()

Details

Go to the URL, focus the editable area, and try typing something in.  Nothing happens.
Reproducible on Nightly (10/17). Also getting some crazy checker boarding occurring as you begin to type.
OS: Mac OS X → Android
Hardware: x86 → ARM
I can reproduce this on my EEE Transformer, using the latest nightly build.
When I press backspace or return, the typed characters suddenly appear.
This might be related to bug 681421.
Depends on: 630576
I can reproduce this on Native Fennec. Pressing backspace or return reveals the typed characters, but the first or last character is often missing.
blocking-fennec1.0: --- → ?
Component: General → IME
Product: Fennec → Fennec Native
QA Contact: general → ime
Possible dupe of bug #728983 ?
> Possible dupe of bug #728983 ?

No. This is strictly an IME bug.
blocking-fennec1.0: ? → soft
what is the behavior on desktop with IME input? If not, how does the events sent by desktop's IME impl differ from Android's?
Mac IME has the same problem.
Assignee: nobody → cpeterson
I am moving this bug to Core product because Mac Firefox does not display the composition string when using Mac's built-in IME. (I don't have access to Windows or Linux to test Firefox on those platforms).

Mac Chrome and Safari correctly display the composition string when using Mac's built-in IME.
Assignee: cpeterson → nobody
Component: IME → Event Handling
Product: Fennec Native → Core
QA Contact: ime → events
Can we get some data on how this works on stock and chrome browsers? Include looking at etherpad and google docs, which are also content-editable apps.
Keywords: qawanted
Ehsan, can you take an initial look at this?  Believed to be a content editable problem.
Assignee: nobody → ehsan
dartlang.org editor works correctly on ICS stock browser, ICS Chrome Beta, Mac Chrome, and Mac Safari, BUT NOT Mac Firefox or Fennec.

Etherpad editor works correctly on ICS stock browser, ICS Chrome Beta, Mac Chrome, Mac Safari, and Mac Firefox. Etherpad has some problems on Fennec that should probably be a different bug.
Removing qawanted as comment 12 seems to answer the questions in comment 10.
Please readd the qawanted keyword if more info is needed.
Keywords: qawanted
Turning on the IME logging in the Java front-end code shows that Gecko does receive the IME event and calls back Java with notifyIMEChange and the updated text, so the bug here is probably a Fennec bug.
Assignee: ehsan → nobody
Component: Event Handling → General
Product: Core → Fennec Native
QA Contact: events → general
So here's what this page does.  When you click on the editable area, it focuses the invisible textarea element it has, and it sets up a keydown event listener on that textarea in order to read the input text.  Once it receives the input text, it updates the div which overlays the textarea which provides rich text formatting (keyword highlighting, etc.)  This div as the class name "db-scroll-x-container", and includes one div per line as a child, plus another div with the class "db-caret" which simulates the caret that you see.  Hope this is useful to debug what's going wrong here.
Assignee: nobody → cpeterson
Filed bug 746769 for the Mac IME bug on this page.
I see that Fennec is receiving key events from Android and Gecko. Fennec is getting the correct text back from Gecko, but does not seem to be updating the textarea.
Assignee: cpeterson → nobody
Component: General → IME
QA Contact: general → ime
(In reply to Chris Peterson (:cpeterson) from comment #17)
> I see that Fennec is receiving key events from Android and Gecko. Fennec is
> getting the correct text back from Gecko, but does not seem to be updating
> the textarea.

The textarea is not visible on the screen.  It is the "db-scroll-x-container" div which contains the elements representing the text, and the page js code keeps those contents updated.

Note that whatever goes wrong here is "fixed" if you press backspace.  Try inputting a few characters immediately followed by a backspace.
No longer depends on: 630576
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 746769
You need to log in before you can comment on or make changes to this bug.