Last Comment Bug 693389 - Update urlclassifier DB for Mozilla com->org move
: Update urlclassifier DB for Mozilla com->org move
Status: VERIFIED FIXED
[mozmill-test-blocked]
:
Product: Toolkit
Classification: Components
Component: Safe Browsing (show other bugs)
: Trunk
: All All
: -- minor (vote)
: Firefox 11
Assigned To: Gian-Carlo Pascutto [:gcp]
:
Mentors:
Depends on:
Blocks: 662213 681920 700607 906304
  Show dependency treegraph
 
Reported: 2011-10-10 12:18 PDT by Gian-Carlo Pascutto [:gcp]
Modified: 2014-05-27 12:25 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
+
fixed


Attachments
Patch 1. Update urlclassifier DB to .org domains (7.13 KB, patch)
2011-10-11 07:17 PDT, Gian-Carlo Pascutto [:gcp]
dcamp: review+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Gian-Carlo Pascutto [:gcp] 2011-10-10 12:18:21 PDT
After the move of all mozilla content from mozilla.com to mozilla.org, users going directly to mozilla.com/firefox/its-a-trap.html will get the correct warning because that URL is in the DB.

However, people who go to directly to mozilla.org/firefox/its-a-trap.html will not get a warning. This could cause confusion if they discover those pages for example due to a Google search.

Update the Urlclassifier DB to the new URL.
Comment 1 Gian-Carlo Pascutto [:gcp] 2011-10-11 07:17:46 PDT
Created attachment 566212 [details] [diff] [review]
Patch 1. Update urlclassifier DB to .org domains
Comment 2 Henrik Skupin (:whimboo) 2011-10-18 02:07:57 PDT
Currently both of our Mozmill tests which check those pages are broken. We need an update of the database to get those fixed. Can we get some progress on the requested review please? Thanks.
Comment 3 Dave Camp (:dcamp) 2011-11-02 13:51:42 PDT
Comment on attachment 566212 [details] [diff] [review]
Patch 1. Update urlclassifier DB to .org domains

Review of attachment 566212 [details] [diff] [review]:
-----------------------------------------------------------------

r+, but did you verify that no other tests are using mozilla.com in server-locations.txt?
Comment 4 Gian-Carlo Pascutto [:gcp] 2011-11-09 08:02:19 PST
>r+, but did you verify that no other tests are using mozilla.com in server-
>locations.txt?

There's this:

# This is here so that we don't load the default live bookmark over
# the network in every test suite.
http://fxfeeds.mozilla.com:80

Make a separate bug for it? Unlike SB tests, it prolly just uses the redirect without issues.
Comment 5 Gian-Carlo Pascutto [:gcp] 2011-11-09 08:27:21 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ff13fc7b5e42
Comment 6 Marco Bonardo [::mak] 2011-11-10 03:14:55 PST
https://hg.mozilla.org/mozilla-central/rev/ff13fc7b5e42
Comment 7 Henrik Skupin (:whimboo) 2011-11-12 10:30:36 PST
Verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111112 Firefox/11.0a1 and a fresh profile.
Comment 8 KLB 2011-12-03 10:37:20 PST
This bug fix appears to be breaking

https://www.mozilla.org/firefox/its-a-trap.html
https://www.mozilla.org/firefox/its-an-attack.html

Which we regularly use as AMO editors to test addons, more specifically themes.  Testing against about:blocked and about:certerror is not sufficient because the behavior isn't 100% the same.

Do I need to file a new bug to get these URLs fixed?
Comment 9 Gian-Carlo Pascutto [:gcp] 2011-12-03 12:09:54 PST
>This bug fix appears to be breaking

Can you explain what you mean? I don't understand.
Comment 10 KLB 2011-12-03 12:13:39 PST
Maybe it isn't this bug exactly, but ever since this morning going to the two links I mentioned above does not result in the proper warnings.
Comment 11 Gian-Carlo Pascutto [:gcp] 2011-12-04 22:54:07 PST
Please file a separate bug.
Comment 12 Henrik Skupin (:whimboo) 2011-12-05 03:31:30 PST
As mentioned above it works with a fresh profile. I haven't actually tested which files of an existing profile have to be removed to get Firefox showing up those warning pages.
Comment 13 KLB 2011-12-05 06:02:13 PST
Gain-Carlo,

Per your instructions, bug 707652 was filed.
Comment 14 Alex Keybl [:akeybl] 2011-12-06 12:13:52 PST
Please nominate for consideration for FF9/10, noting any possible risks. com->org feels low risk to me though.
Comment 15 Gian-Carlo Pascutto [:gcp] 2012-01-22 22:47:22 PST
Comment on attachment 566212 [details] [diff] [review]
Patch 1. Update urlclassifier DB to .org domains

[Approval Request Comment]
Regression caused by (bug #): Reworking of the Mozilla.com/org websites
User impact if declined: Users might inadvertently think the phishing protection no longer works
Testing completed (on m-c, etc.): Baked for several weeks in Aurora
Risk to taking this patch (and alternatives if risky): None known
Comment 16 Alex Keybl [:akeybl] 2012-01-23 08:44:04 PST
Comment on attachment 566212 [details] [diff] [review]
Patch 1. Update urlclassifier DB to .org domains

[Triage Comment]
Simple .com -> .org switch for its-an-attack.html and its-a-trap.html. Approved for beta.
Comment 17 Gian-Carlo Pascutto [:gcp] 2012-01-23 12:31:51 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/9ba868a26c6c
Comment 18 Gian-Carlo Pascutto [:gcp] 2012-01-30 13:27:03 PST
*** Bug 707652 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.