Loading "Add-ons for your Fennec" pane makes Fennec unresponsive for a second or two

RESOLVED DUPLICATE of bug 689692

Status

RESOLVED DUPLICATE of bug 689692
7 years ago
7 years ago

People

(Reporter: justin.lebar+bug, Unassigned)

Tracking

Trunk
ARM
Android

Details

STR:

 * Clean install of Fennec, cold start.
 * When the browser appears, try to scroll right or left.

Actual results:

 * Scrolling is very jerky until "Add-ons for your Fennec" pane finishes loading.

Filling in this pane seems really unimportant compared to fast startup.
Tested on my Nexus S running Android 2.3.6.
Is it just the add-ons pane? We landed a few patches recently to make the "Tabs from last time" and "Addons for Firefox" less of a hit:

bug 692712 and bug 691534

But also notice a few other SQLite related things that happen after the first page has "loaded" in bug 673253. A few patches are in progress for the dependent bugs.

Lastly, I filed bug 689692 to remove this add-ons pane and replace with something less obtrusive to startup.

Duping this bug to bug 689692, but I wanted to put some of the other bugs/info here too.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689692
You need to log in before you can comment on or make changes to this bug.