8-bit's occasionally displayed as garbage.

VERIFIED DUPLICATE of bug 70525

Status

MailNews Core
Internationalization
VERIFIED DUPLICATE of bug 70525
18 years ago
10 years ago

People

(Reporter: Michael Kolmodin, Assigned: nhottanscp)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
BuildID:    Mozilla 0.8 release (Windows/talkback): 
            (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215

Initially, MailNews displays messages containing 8-bit
characters (Swedish umlauts) OK but fails after 
reading a newsgroup.

Reproducible: Always

Steps to Reproduce:

1 Subscribe to a "normal" IMAP server, verify that the
  mailbox contains a message with the headers
  Content-Type: text/plain and
  Content-Transfer-Encoding: 8bit 
  (free from my memory, details might be wrong here)

2 Subscribe to the n.p.porkjockeys newsgroup at
  news.mozilla.org

3 Restart Mozilla.

4 Start MailNews, select the IMAP account. Verify that
  the 8bit message looks OK.

5 Select the n.p.porkjockeys newsgroup at 
  news.mozilla.org. View one message

6 Select once again the IMAP account. View the 8bit
  message. This time the 8bit characters are garbled.

Actual Results:  8-bit characters garbled

Expected Results:  8-bit characters displayed as first time
(Reporter)

Comment 1

18 years ago
'Intl' keyword.
Keywords: intl
Possible related to bug 66757 / bug  69124 ?
(Reporter)

Comment 3

18 years ago
Sun (Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; 0.8) Gecko/20010214)
seems to work OK. So this is a Windows Thing.

--m
(Reporter)

Comment 4

18 years ago
Reading Matthias' comments, I've tested again. For the moment, I'm unable
to reproduce the bug. **** :-(

--m

Comment 5

18 years ago
Marked it as WFM for now. Please reopen it if you see the problem again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

18 years ago
It happened again. Basically, I was doing the same thing: Reading mail,
reading news, reading mail again. When the bug occurs, it affects all messages.
I will make a reasonable try to find out what triggers the bug, but it might
be hard...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

18 years ago
Created attachment 25928 [details]
Strange news header window
(Reporter)

Comment 8

18 years ago
Something is really strange... I got the enclosed news header display when
viewing n.p.performance newsgroup. Basically, one message header from a 
fellow Swede looks perfectly OK whereas next header display the Swedish 
umlaut as garbage. This is news header display on a Solaris, but it's 
propably the same bug (?)

Changing platform/OS to 'All'. I will propably need help to figure out what's
going on here.
OS: Windows 2000 → All
Hardware: PC → All

Comment 9

18 years ago
Did you open seperate windows for mail and news?
(Reporter)

Comment 10

18 years ago
I've always used the same window for mail and news so far. This one occured
before I even tried to read mail. When checking the mail after this strange
news display, it looked OK. 

Solaris version: Moz/5.0 (X11; U; SunOS 5.8 sun4u; en-US; 0.8) Gecko/20010214

Updating summary.
Summary: 8-bit's displayed as garbage after reading news. → 8-bit's occasionally displayed as garbage.
(Reporter)

Comment 11

17 years ago
Have now been using moz for several weeks without encountering the bug.
Did something happen in the transition to the new version? Marking 
WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 12

17 years ago
dup of bug 70525
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Assignee)

Comment 13

17 years ago

*** This bug has been marked as a duplicate of 70525 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 14

17 years ago
Marked it as a dup of bug 70525. It is fixed in 0.9.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.