display email addresses of the users who were bcc'd in sent mails (if Gmail's SMTP server is used to send mail, it's impossible to hold sent mail copy with BCC: in Gmail's folder)

RESOLVED DUPLICATE of bug 589303

Status

RESOLVED DUPLICATE of bug 589303
7 years ago
3 years ago

People

(Reporter: barsky, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2
Build ID: 20110902133214

Steps to reproduce:

I sent email to users using bcc and subsequently looked at the email stored in the Sent folder.


Actual results:

When I look at the email stored in the Sent folder, it is not possible to retrieve the email addresses of the users to whom I have sent email using bcc


Expected results:

I would like to be able to retrieve the email addresses of the users to whom I have sent email using bcc.
Is BCC: header seen in message source of the sent mail copy in your Sent folder?
Gmail IMAP? Is mail sent via Gmail's SMTP server?
(Reporter)

Comment 2

7 years ago
I use different outgoing servers including Gmail's SMTP server often but not always.  Will that make a difference?  If so, I could try to remember to change the outgoing server when I am sending out an email using bcc's so as to be able to retain the email addresses of the bcc recipients.  When I look at the mail copy in my Sent folder, I do not see a BCC: header.  I am using IMAP.  Thank you.
Problem with Gmail is next.
(1) Upon SMTP send, Gmail's SMTP automatically saves sent mail data, 
    no BCC: header version because real mail data passed to SMTP server,
    to [Gmail]/Sent Mail folder of Gmail IMAP.
(2) When saved by Tb to "sent folder specified at Copies&Folders" after send,
    Tb adds BCC: header in mail source for future reference of BCC:.
(3) Gmail doesn't keep multiple versions of same mail.
    Because difference between mail source at (1) and mail source at (2) is BCC:
    header only, mail at (1) and mail at (2) are same mail for Gmail.
    So, if "sent folder specified at Copies&Folders" is Gmail IMAP folder,
    mail data passed to Gmail IMAP at (2) is not kept by Gmail.
    Gmail keeps mail data at (1) only.

To avoid above issue due to particularity of Gmail, one of next is needed to obtain mail data with BCC: header.
(A) Don't use Gmail's SMTP server. Mail data at (1) is not kept by Gmail, so
    mail data at (2), with BCC:, is kept even when Gmail IMAP folder.
(B) Don't use Gmail IMAP folder as "sent folder specified at Copies&Folders".
    If local mail folder or folder of ordinal IMAP server, mail data at (2),
    with BCC:, is saved as sent mail copy.
B does Wada's explaination helped/ do you still have the issue ?
Summary: display email addresses of the users who were bcc'd in sent mails → display email addresses of the users who were bcc'd in sent mails (if Gmail's SMTP server is used to send mail, it's impossible to hold sent mail copy with BCC: in Gmail's folder)
Bug reporter ?
Whiteboard: [closeme 2012-02-01]
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Whiteboard: [closeme 2012-02-01]
Duplicate of bug: 589303
You need to log in before you can comment on or make changes to this bug.