Loading/busy/spinning mouse indicator is now generic in Firefox 10.0a1

RESOLVED DUPLICATE of bug 709259

Status

()

RESOLVED DUPLICATE of bug 709259
7 years ago
7 years ago

People

(Reporter: james.bugzilla, Unassigned)

Tracking

({regression})

Trunk
All
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox10-)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0a1) Gecko/20111010 Firefox/10.0a1
Build ID: 20111010031016

Steps to reproduce:

As of September 24 Nightly (10.0a1) the mouse progress icon is now a tiny generic one instead of the mouse icon theme loading animation/icon.

This still works in Sept 23 and earlier Nightly on Linux 32-bit. I do believe this may be Linux only as I have not seen such complaints by Windows and Mac users since.


Actual results:

With ui.use_activity_cursor set to true I get a tiny generic not animated mouse/watch icon.


Expected results:

In Sept 23 and earlier Nightly with ui.use_activity_cursor set to true I would get the progress loading icon from X11 mouse theme.
(Reporter)

Updated

7 years ago
tracking-firefox10: --- → ?
Summary: Loading/busy/spinning mouse indicator is now generic → Loading/busy/spinning mouse indicator is now generic in Firefox 10.0a1
(Reporter)

Comment 1

7 years ago
I remembered about the about:buildconfig as I should have posted it in OP.

For the Sept 24 9.0a1 Nightly where the mouse load icon was made broken (put 10.0a1 by mistake in OP as merge had not happen just yet). There were 35 changesets for this build.

http://hg.mozilla.org/mozilla-central/rev/c71229984353
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=c71229984353


The Sept 23 build that the Mouse load works fine on is 
http://hg.mozilla.org/mozilla-central/rev/259d1556c221


Changes that happened in between those two Nightly builds.

bjacob@mozilla.com
Fri Sep 23 17:29:59 2011 -0700	 http://hg.mozilla.org/mozilla-central/rev/b4fd4fd0dc3f

rcampbell@mozilla.com
Fri Sep 23 15:43:20 2011 -0700	 http://hg.mozilla.org/mozilla-central/rev/8b972cc648e2

tmielczarek@mozilla.com
Fri Sep 23 05:41:10 2011 -0700	 http://hg.mozilla.org/mozilla-central/rev/959c1e6bdb11

bmo@edmorley.co.uk
Fri Sep 23 04:16:10 2011 -0700	 http://hg.mozilla.org/mozilla-central/rev/939ac50b2b67
(Reporter)

Updated

7 years ago
Version: 10 Branch → Trunk
Mozilla/5.0 (X11; Linux x86_64; rv:10.0a1) Gecko/20111021 Firefox/10.0a1

STR used:
1. Set ui.use_activity_cursor to true in about:config
2. Open a webpage.
3. Move the mouse cursor in the page.

Actual result: the mouse progress icon does not load the animation anymore.

Confirmed on Ubuntu 11.10. Mac OS 10.6 displays the same new graphic progress icon, but loads the animation properly (is this intentional?). Windows has other graphics for the cursor progress icon. Thanks to James' comments:

Last good nightly: 2011-09-23
First bad nightly: 2011-09-24

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=259d1556c221&tochange=c71229984353
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: x86 → All
(Reporter)

Comment 4

7 years ago
Thank you for Confirmation.

For the Linux build as per comment 2, I narrowed it down to http://hg.mozilla.org/mozilla-central/rev/939ac50b2b67 as it still worked in the hourly before that and has not worked properly since.

Comment 5

7 years ago
[Triage Comment]
CC'ing Ed since this is suspected to be a regression caused by the above change.
tracking-firefox10: ? → +
Keywords: regression

Comment 6

7 years ago
The changeset in comment 4 is just a mozilla-inbound merge, the actual cause will be one of the other changesets in that push:
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=939ac50b2b67

To narrow it down, you can download the mozilla-inbound tinderbox builds from:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-inbound-linux64/
(Reporter)

Comment 7

7 years ago
Those mozilla-inbound builds did not go back far enough at the time of your comment. Also I use the 32-bit builds.

Anyways it appears to have been fixed? as the mouse loading animation is working fine in Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111215 Firefox/11.0a1
http://hg.mozilla.org/mozilla-central/rev/beac16509534

Comment 8

7 years ago
> The changeset in comment 4 is just a mozilla-inbound merge, the actual cause will be one of the other
> changesets in that push:
> http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=939ac50b2b67

Making a WAG I suspected:
875cb4f20eac	Martin Stransky — Bug 627699 - Port GTK2 to GTK3: Partial patch for nsWindow.cpp and associated files;

And indeed Bug 627699 has a dependency on:
Bug 709259 - Appearance of "spinning" cursor regressed sometime between Thunderbird 8 and 9.


Which is fixed for Firefox 11.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709259

Updated

7 years ago
tracking-firefox10: + → -
You need to log in before you can comment on or make changes to this bug.