Tab goes behind the browser window while dnd if returning from fullscreen

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: andrei.domuta, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 566140 [details]
tab behind main window when dnd

Build IDs:  
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111010 Firefox/10.0a1 (Win 7 x64)
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111010 Firefox/10.0a1 (Win 7 x86)


Steps to reproduce:
1. Launch Firefox on a clean profile and make sure to have 2 browser windows available
2. Detach one tab from a window and while dragging hit F11 to have the other window fullscreen (without releasing the tab)
3. Close Fullscreen mode with F11 and drop the tab to the destination window

Expected result:
In step 3 tab animation should be visible in the tab strip of the destination window

Actual result:
In step 3 the tab is behind the destination window

*Notes:
-> This bug is a regression from the behavior before the landing of the bug 455694 (implementation of the feature Tab Animation)
-> This is Windows only bug. The issue is not reproducible on Mac or Linux
-> This issue would depends on the fix suggested in bug 689575 (disable keyboard shortcuts while tab animation is active)
-> Attaching a screen shot of the issue
(Reporter)

Updated

7 years ago
Depends on: 689575
(Reporter)

Updated

7 years ago
Keywords: regression
(Reporter)

Updated

7 years ago
Whiteboard: [qa+]

Comment 1

6 years ago
Patch in bug 455694 was backed out.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: regression
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.