UW SMTP: Lost composed mail when SMTP server denied service (no-relaying)

VERIFIED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
VERIFIED WORKSFORME
17 years ago
9 years ago

People

(Reporter: gekacheka, Assigned: Scott MacGregor)

Tracking

({imap-interop})

Trunk
x86
Windows NT
imap-interop

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010219
BuildID:    20010215 (0.8)

My organization's SMTP server only accepts mail either for 
 o delivery to users at the site
 o mail sent by users who read mail from the site

When I tried sending mail before reading mail, the mail composition window went
away normally, but after a short pause a dialog popped up saying that the SMTP
server denied service: no relaying.  

I expected that Mozilla would have saved my message either in Sent, Unsent,
Drafts, or Trash folders, but it did not appear in any of the folders.  

--> mozilla should save mail in this case, perhaps in the unsent folder and/or
it might bring the Composition window back with the composed mail so users can
see their message isn't lost.

Reproducible: Didn't try
Steps to Reproduce:
1. set SMTP server to one that does not accept relaying
2. attempt to send mail
3. wait while status line says "sending mail" 
4. if fails, dialog appears saying service denied, no -relaying

Actual Results:  Composed message was lost.

Expected Results:  Either 
 o Composition window re-appears with composed message, or
 o composed message is saved to Unsent messages folder

(I haven't been able to reproduce it because the SMTP mailer has a long timeout,
and I need to continue to read mail.)

(I encountered the problem with the 0.8 release build; I am reporting this from
the 2001021904 build.)

i hope this is enuf!

Comment 1

17 years ago
Ccing myself, this bug related to bug 69123.
Ccing Seth, Seth, how do you think about this bug?
Currently, from Commercial build - the compose window will display after the 
SMTP server denied service, but how about save this unsent message in the unsend 
folder? Which way suppose to work for the compose window for the SMTP server 
denied service?

Comment 2

17 years ago
Oops! Typo! I mean bug 69163.

Comment 3

17 years ago
I couldn't reproduce this problem on today's commercial build 02-19-06-Mtrunk 
build. Is this specific problem on Mozilla build?
QA Contact: esther → huang

Comment 4

17 years ago
This WORKSFORME just fine. No loss of mail. Marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
Verified on WinNT 05-25-09-trunk build for our internal UW server w/similar SMTP
setup.
The compose window did display after the alert describing SMTP server denied
service. -- Verified as worksforme -- 
Status: RESOLVED → VERIFIED
Keywords: interop
Summary: Lost composed mail when SMTP server denied service (no-relaying) → UW SMTP: Lost composed mail when SMTP server denied service (no-relaying)

Comment 6

17 years ago
Please refer to bug 69163 for more discussion of the SMTP Relaying denied Alert.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.