jsapi.cpp fails to compile on mingw due to JS_STATIC_ASSERT failure

RESOLVED DUPLICATE of bug 693393

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 693393
6 years ago
6 years ago

People

(Reporter: Jacek Caban, Assigned: Jacek Caban)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 566198 [details] [diff] [review]
fix v1.0

It's because jsapi.h assumes that AutoCompartment's size is compiler-dependent, but it's ABI-dependent.
Attachment #566198 - Flags: review?(justin.lebar+bug)
I pushed a fix for this yesterday in bug 693393.  Does that work for you?
(Assignee)

Comment 2

6 years ago
Yes, thanks. It looks like I last pulled from m-c short after merge.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 693393
I'm sorry we put you through the trouble of patching this.  :(  Glad to hear it's working!
(Assignee)

Updated

6 years ago
Attachment #566198 - Flags: review?(justin.lebar+bug)
You need to log in before you can comment on or make changes to this bug.