Password reset working for blank email addresses

VERIFIED INVALID

Status

Firefox Affiliates Graveyard
affiliates.mozilla.org
--
minor
VERIFIED INVALID
7 years ago
2 years ago

People

(Reporter: Tobbi, Unassigned)

Tracking

unspecified

Details

(Whiteboard: [dev], URL)

(Reporter)

Description

7 years ago
On https://affiliates-dev.allizom.org/en-US/accounts/forgot_password you can enter anything, then click the send button and it will say password reset sent.

Comment 1

7 years ago
Tobbie: This is expected behavior for invalid email addresses as we don't want to give anyone an indication that an email address is real.

A blank email is something different and we should trap that error and send them back to the forgot password page. I will put this in 1.1.
Summary: Password reset working for blank / invalid email addresses → Password reset working for blank email addresses
Target Milestone: --- → 1.1

Updated

6 years ago
Whiteboard: [dev]

Comment 2

6 years ago
Needs more discussion is this is really bad at all.

Updated

6 years ago
Assignee: nobody → mozilla+bugzilla

Updated

6 years ago
Assignee: mozilla+bugzilla → nobody
Marking as invalid due to BrowserID.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Depends on: 687500
Resolution: --- → INVALID
Verified invalid now that BrowserID has landed. This is no longer part of the workflow. Thx for bringing this to the communities attention.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

6 years ago
Product: Websites → Firefox Affiliates
(Assignee)

Updated

2 years ago
Product: Firefox Affiliates → Firefox Affiliates Graveyard
You need to log in before you can comment on or make changes to this bug.