If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Next button should give message focus, so delete button then deletes message

VERIFIED DUPLICATE of bug 33507

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED DUPLICATE of bug 33507
17 years ago
13 years ago

People

(Reporter: gekacheka, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010219
BuildID:    

Currently, if I select an inbox to get mail, then hit the next, then hit the
delete button, it thinks I'm trying to delete the inbox rather than the message.
  --> NEXT button, if successful, should bring focus to the next
      message so that the DELETE button can be used on the message.


Reproducible: Always
Steps to Reproduce:
0. send yourself some test mail
1. get mail
2. select an inbox (possibly a filter destination folder)
3. hit NEXT button to go to first unread message
4. hit DELETE button to delete message?

Actual Results:  Mozilla acts as if I'm deleting the folder (asks am I sure I
want to move the folder to trash).

Expected Results:  Next button should shift focus to the newly displayed
message, so that delete button will delete the message.

(Messages are sorted forward by date, most recent last)
(Workaround: use pointer to move focus from folder to message.  Not sure how to
do this without pointer.)

Comment 1

17 years ago
We have a lot of focus related bugs logged such as thi ... probably a
duplicate/side issue of 33507

*** This bug has been marked as a duplicate of 33507 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED

Comment 3

16 years ago
Works for me with RC2
When hit next, the message pane will get the focus, so the delete works fine.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.