Status

Core Graveyard
Nanojit
RESOLVED WONTFIX
6 years ago
4 years ago

People

(Reporter: Chris Dearman, Assigned: Rick Reitmaier)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-nanojit, fixed-in-tamarin)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 566381 [details] [diff] [review]
Implement CMOVD for MIPS

Nanojit random tests fail when using CMOVD

This patch is dependent on https://bugzilla.mozilla.org/attachment.cgi?id=566358

With both patches applied all of the nanojit testcases (including random) pass and there are no new regressions on tamarin-redux
(Reporter)

Updated

6 years ago
Attachment #566381 - Flags: review?(nnethercote)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment on attachment 566381 [details] [diff] [review]
Implement CMOVD for MIPS

Review of attachment 566381 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, but consider this a very "light" review since I don't know MIPS.
Attachment #566381 - Flags: review?(nnethercote) → review+
(Reporter)

Comment 2

6 years ago
(In reply to Nicholas Nethercote [:njn] from comment #1)
> r=me, but consider this a very "light" review since I don't know MIPS.

Should I get someone else to take a look at this or are you ok to merge it as is?

Thanks
Oh, go for it.  I can't remember -- do you have commit access?

Comment 4

6 years ago
R+ too, and you can also use rreitmai or wmaddox for review+land requests; they're even in your timezone.

If the style of prepareResultReg and freeResourcesOf is patterned after ARM then it should be ok.
(Reporter)

Updated

6 years ago
Whiteboard: checkin-needed
(Reporter)

Comment 5

6 years ago
I don't have commit access. Will someone commit this?

Comment 6

6 years ago
to rreitmai 4 commit.
Assignee: nobody → rreitmai
(Assignee)

Comment 7

6 years ago
chris http://hg.mozilla.org/projects/nanojit-central/rev/af2112567164
Whiteboard: checkin-needed → checkin-needed,fixed-in-nanojit

Comment 8

6 years ago
changeset: 6735:057d70ce3455
user:      Chris Dearman <chris>
summary:   Bug 693845 - CMOVD support for MIPS (r+nnethercote)

http://hg.mozilla.org/tamarin-redux/rev/057d70ce3455

Updated

6 years ago
Whiteboard: checkin-needed,fixed-in-nanojit → fixed-in-nanojit, fixed-in-tamarin
Component: Nanojit → Nanojit
Product: Core → Core Graveyard
Nanojit has been dead for several years. Its Bugzilla component has been moved to the graveyard (bug 984276).

I checked all the open bugs. They're all uninteresting, so I'm WONTFIXing them all. Apologies for the bugspam.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.