Search: Can't cancel authentication when seach launched from Acct Level

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
17 years ago
6 years ago

People

(Reporter: laurel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

17 years ago
Using feb19 commercial trunk, all platforms

When launching Search messages from an IMAP account level (using menu item or
link in Acct Central page) before having logged into that account, you cannot
cancel the authentication process; the password dialog keeps reappeearing after
Cancel or close.  You can indeed cancel a password dialog if searching from a
folder within that account, or also can cancel from getting mail from that
account level; in these cases the password dialog does not appear again until
needed.

Steps to reproduce:
1.  Launch to mail where default/first account is IMAP, password not remembered
in password manager.  You are left at the Account level with the "Account
Central" page displayed.
2.  Click the "Search Messages" link in the Account Central page or launch
search via the menu item Search|Search Mail/News Messages.
3.  Initiate a search (default account, account-wide search is default).
4.  Password dialog appears for authentication to that default IMAP account.
5.  Cancel or close the dialog. Dialog reappears ad infinitum...cannot cancel
the authentication process in this situation.

Actual results:  After Cancel or Close, the authentication dialog reappears and
will continue to do so  -- never cancels.

Expected:  After Cancel or Close, the password dialog should not reappear until
I reinitiate a process which needs authentication.
(Reporter)

Updated

17 years ago
QA Contact: esther → laurel
Summary: Search: Can't cancel authentication when search launched from Acct Level → Search: Can't cancel authentication when seach launched from Acct Level
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 1

17 years ago
marking nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → Future

Comment 2

17 years ago
reassigning to naving
Assignee: gayatrib → naving
mass re-assign.
Assignee: naving → sspitzer

Comment 4

15 years ago
FYI: I have just file a bug report (#220335) reporting a similar behavior of the
authentication dialog box, when reading a certain web page.
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search

Comment 5

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 6

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 7

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 8

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 9

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 10

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Assignee: mail → nobody
QA Contact: search → message-display

Comment 11

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Updated

7 years ago
Depends on: 620515

Comment 12

7 years ago
May be hidden by bug 620515.
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---

Comment 13

6 years ago
Tested on lastest trunk.
Get one dialog box which does not reappear after cancelling - search terminates.
-> WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [Halloween2011Bug]
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.