Screenshot in details view of search pane not shown anymore

RESOLVED FIXED in ACR-1.0

Status

addons.mozilla.org Graveyard
Compatibility Tools
P1
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: whimboo, Assigned: mackers)

Tracking

({regression})

ACR-0.9
ACR-1.0
regression
Bug Flags:
in-testsuite ?

Details

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111011 Firefox/9.0a2 ID:20111011042016

When searching for an add-on and opening the details view in the search pane the screenshot(s) are not shown anymore. This is a regression on Aurora. Could this have been caused by bug 664895?

Steps:
1. Open the Add-ons Manager and search for 'Mozmill Crowd'
2. Open the details view of the crowd extension in the search pane

There is no screenshot shown. 

Vlad or Virgil, can one of you please run a regression test? Thanks.
Flags: in-testsuite?
Version: 5 Branch → 9 Branch
I'm seeing screenshots on OSX with other extensions, ACR and Flashgot f.e.

I did see the problem with mozmill once but not a second time
What do you mean with 'a second time'? Whenever I open the details view, I never see screenshots. This is the search pane only, and not the extensions pane.
I closed the add-ons manager and reopened it to try again and it worked after that
The Addon Compatibility Reporter extension is out of date and is calling |new AddonManagerPrivate.AddonScreenshot| with the wrong arguments:

https://addons.mozilla.org/en-US/firefox/files/browse/133331/file/chrome/content/modules/AddonRepository.jsm#L972
Component: Add-ons Manager → Compatibility Tools
Keywords: regression, regressionwindow-wanted
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → compatibility
Version: 9 Branch → ACR-0.9
This has been introduced by bundling the AddonsRepository.jsm file to ACR, which was added by bug 678787. If we would update the file in the ACR extension, we will break older versions of Firefox. Can we put multiple versions of the file into that folder and specify it's usage per version by the manifest?
Keywords: regression

Comment 6

6 years ago
Ack, we anticipated that this might cause breakage somewhere down the line.

Dave, please revisit this ... preferably a solution where we don't have to bundle the file at all.
Assignee: nobody → dave
Priority: -- → P1
Target Milestone: --- → ACR-1.0
Brian: bug 581065 is due to land which should enable you to stop bundling the file.
(Assignee)

Comment 8

6 years ago
r96755 of ACR will not use the CustomAddonRepository.jsm if the application is Firefox/Thunderbird >= 9.0a2.
Status: NEW → ASSIGNED

Comment 9

6 years ago
WFM on the first try with Mozimill on FF9.0 on a Mac running 10.7. Sounds intermittent at best.
tracking-firefox9: ? → -
(In reply to David McNamara [:mackers] from comment #8)
> r96755 of ACR will not use the CustomAddonRepository.jsm if the application
> is Firefox/Thunderbird >= 9.0a2.

Marking this as FIXED then. WFM in:
Mozilla/5.0 (Windows NT 6.0; rv:10.0) Gecko/20100101 Firefox/10.0

David, just curious, how is search handles in versions greater than 9.0a2?
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 11

6 years ago
(In reply to Brian King (Briks) [:kinger] from comment #10)
> David, just curious, how is search handles in versions greater than 9.0a2?

The addon manager now takes care of showing/hiding compatible/incompatible add-ons.
(Assignee)

Comment 12

6 years ago
(In reply to David McNamara [:mackers] from comment #11)
> The addon manager now takes care of showing/hiding compatible/incompatible
> add-ons.

Although this seems broken since compat-by-default - Searching for incompatible add-ons in the addon manager returns nothing.
(In reply to David McNamara [:mackers] from comment #12)
> (In reply to David McNamara [:mackers] from comment #11)
> > The addon manager now takes care of showing/hiding compatible/incompatible
> > add-ons.
> 
> Although this seems broken since compat-by-default - Searching for
> incompatible add-ons in the addon manager returns nothing.

Filed bug 717544.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.