Awesome Bar retains focus after page has been loaded

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: jhatax, Unassigned)

Tracking

10 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by New Tab King])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111012 Firefox/10.0a1
Build ID: 20111012031018

Steps to reproduce:

Using the keyboard in a new Nightly window:
1. Alt + D
2. Start typing, "nytim"
3. Awesome Bar shows match to nytimes.com
4. Press the down arrow to select nytimes.com
5. Press the right arrow to go to the end of the url "nytimes.com"
6. Press Enter
7. After page load completes, press the Down arrow to scroll


Actual results:

The Location Bar retained focus instead of delegating focus to the Content Area.
Pressing the Down arrow reopens the awesome bar search results menu


Expected results:

Pressing the Down arrow should scroll the page down
(Reporter)

Comment 1

7 years ago
Before marking this bug as WFM, please try the following to reproduce this issue:

1. Restart Firefox
2. Create a new tab or window
3. Use the keyboard shortcuts and arrow keys

I just reproduced this issue in a new tab's 1st visit to nytimes.com and gigaom.com.

Comment 2

7 years ago
WFM with Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20111223 Firefox/12.0a1 ID:20111223032107

Are you still experiencing with the latest nightly?
(Reporter)

Comment 3

7 years ago
I cannot reproduce this with the latest nightly and a new profile. 

Fwiw, the bug manifests itself only when the New Tab king extension is installed.

Comment 4

7 years ago
Thanks for tracking that down and posting back Manoj. It would be great if you could let the extension author know.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: Location Bar → Extension Compatibility
QA Contact: location.bar → extension.compatibility
Resolution: --- → INVALID
Whiteboard: [Caused by New Tab King]
You need to log in before you can comment on or make changes to this bug.