Last Comment Bug 694135 - IndexedDB: Don't throw if there are unknown properties in the options objects to createObjectStore/createIndex
: IndexedDB: Don't throw if there are unknown properties in the options objects...
Status: RESOLVED FIXED
: addon-compat, dev-doc-complete
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Jonas Sicking (:sicking) No longer reading bugmail consistently
:
:
Mentors:
Depends on:
Blocks: idb
  Show dependency treegraph
 
Reported: 2011-10-12 14:04 PDT by Jonas Sicking (:sicking) No longer reading bugmail consistently
Modified: 2012-03-22 11:51 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to fix (12.99 KB, patch)
2011-11-07 19:19 PST, Jonas Sicking (:sicking) No longer reading bugmail consistently
bent.mozilla: review+
Details | Diff | Splinter Review

Description Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-10-12 14:04:11 PDT
Such properties should just be ignored.
Comment 1 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-11-07 19:19:39 PST
Created attachment 572722 [details] [diff] [review]
Patch to fix

This fixes things.

Turns out that "" is actually a valid key path and simply refers to the value itself. So it actually makes sense to use that on an objectStore which turns the store into a set.
Comment 2 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-11-07 19:30:49 PST
Comment on attachment 572722 [details] [diff] [review]
Patch to fix

Review of attachment 572722 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good!
Comment 3 Jonas Sicking (:sicking) No longer reading bugmail consistently 2011-11-07 22:31:11 PST
Checked in https://hg.mozilla.org/mozilla-central/rev/e73f34291541

Thanks for the quick review!
Comment 4 Jean-Yves Perrier [:teoli] 2011-11-21 02:23:35 PST
I've updated:
https://developer.mozilla.org/en/IndexedDB/IDBDatabase#section_12
https://developer.mozilla.org/en/IndexedDB/IDBObjectStore#section_15

and a mention in 
https://developer.mozilla.org/en/Firefox_10_for_developers

(Sidenote: the latest draft use a different type for passing the parameter, but I wasn't able to find a bug to adapt Firefox implementation)
Comment 5 :Ms2ger (⌚ UTC+1/+2) 2011-11-21 02:44:18 PST
Note that the fact that we don't implement dictionary types yet is not detectable from script; they are just specese to refer to simple JS objects, so I don't think the warnings are necessary.

Note You need to log in before you can comment on or make changes to this bug.