Thunderbird (ver. 3 thru 7) unable to POP Gmail

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: drbobski, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol log])

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 566706 [details]
prefs.js

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

POP3 stopped working with Gmail accounts; still works with Yahoo, Verizon and Mac.
Tried to delete and reinstall Gmail accounts.  Situation remained the same.  Tried to install older versions of TB which had worked with Gmail POP3 in the past.  Only change was that I lost access to ALL emails stored in TB (in both the active .profile folder AND the backup .profile).


Actual results:

Deletes worked.  Default set-up of Gmail accounts were saved but did not work.  Attempts to save changes to Gmail accounts failed (i.e., changes were not saved -- accounts reverted to original settings after exiting account edit window).


Expected results:

1.) Edits to accounts should save so that changes remain in effect after closing edit window.
2.) Should be able to use POP3 with Gmail accounts since POP3 is enabled on Gmail side and accounts on TB are set up as POP and not IMAP.
3.) Should not lose access to previous emails when change TB version.
Hum I just created a pop gmail account on 8.0b2 and it worked flawlessly.

So what's the status of your TB install now ? does going back to 7 helps ?
(Reporter)

Comment 2

7 years ago
No. Set all gmail accounts to forward mail to my yahoo account & manually transferred existing email individually via forward.  Think the problem is with a corrupted prefs.js file but I do not know how to fix the file (comments in file say not to edit it and other methods do not seem to save changes).

This corruption seems like the most likely root cause since problem persists regardless of which version is installed.  Wiping out the prefs.js file & allowing TB install to recreate it might work but will probably cause the loss of existing email already on my pc.

Any recommendations?
Version: unspecified → 7
The file can be edited as long as Thunderbird is not running.

Whipping out would remove the accounts , but not the emails themselves, and they might not be very visible. I would recommend to make Thunderbird go offline and stay offline on restart so that when you play with your prefs.js file you don't screw your emails up.
(Reporter)

Comment 4

7 years ago
Created attachment 571881 [details]
POP3 log for Thunderbird

Log file attached for TBird access of gmail pop3 account (which does not work) and mac pop3 account (which does work).  Pop3 also works for Verizon and Yahoo email accounts.

When attempt to set up a gmail account, setup finds gmail account and accepts username and password.  When "create account" button is hit, get error message that username and/or password is incorrect.  

Manually setting up the gmail account as directed for IMAP results in being able to sync. Tbird and Gmail. 

Manually setting up the gmail account as directed for POP3 results in NOT being able to download messages from Gmail to Tbird.
is Pop3 enabled in your gmail web ui ?
Component: Account Manager → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: account-manager → networking.pop
(In reply to Bob Dobrowolski from comment #4)
> Created attachment 571881 [details]
> POP3 log for Thunderbird

I don't seen anything suspicious here - except that gmail is refusing to log you in hence comment 5.
Whiteboard: [has protocol log]
(Reporter)

Comment 7

7 years ago
Yes, gmail web ui has Pop3 access enabled.

What I do not understand is WHY gmail is refusing to log me in -- I can log in and access the accounts via IMAP using the same userids and passwords as I use for Pop3.  I use the ports and security setups as detailed in the gmail FAQs for use of Pop3 with TB 3.0 (the only TB version listed in the FAQs).

I do note that the prefs.js file gets confused (i.e., corrupted) whenever I change an existing account or add a new one.  There may be a problem with how the account functions edit that file.
If mail.mac.com, server returns +OK within 2 seconds after connection request from Tb.
> ##### The following lines are from attempting to access mail.mac.com via pop3 (zero messages in inbox)
> 2011-11-04 04:32:12.500000 UTC - 0[72f140]: Setting server busy in nsPop3Protocol::LoadUrl
> 2011-11-04 04:32:14.491000 UTC - 0[72f140]: RECV: +OK Messaging Multiplexor
However, when pop.gmail.com, nothing is returned from server, and it looks that timeout happned after 21 seconds or that connection request was rejected after 21 seconds.
> ##### The following lines are from attempting to access pop.gmail.com via pop3 (3 messages in inbox)
> 2011-11-04 04:31:46.065000 UTC - 0[72f140]: Setting server busy in nsPop3Protocol::LoadUrl
> 2011-11-04 04:32:07.291000 UTC - 0[72f140]: Entering NET_ProcessPop3 0
> 2011-11-04 04:32:07.291000 UTC - 0[72f140]: POP3: Entering state: 24
> 2011-11-04 04:32:07.292000 UTC - 0[72f140]: POP3: Entering state: 25
http://kb.mozillazine.org/Session_logging_for_mail/news
  POP3 connection states
    24  ERROR_DONE
    25	FREE

Following is general guide by Gmail for Gmail's POP3 account setup of mailer.
http://mail.google.com/support/bin/answer.py?answer=13287
Is your setup correct? Can you write down Account Settings/Server Settings for the Gmail POP3 account in Tb?
 Server Type:, Server Name:, Port:, Connection Security:, Authentication Method:

Because you can access via IMAP, your thunderbird.exe's internet access is not prohibited by anti virus software and/or personal firewall software. However, mail scanner of anti virus software can intercept Tb's POP3 access and IMAP access independently. Do you enable mail scanner? If yes, is your setup correct?
(Reporter)

Comment 9

7 years ago
Without making any changes to my system, POP3 suddenly started (& continues) to work properly with all email servers, including Gmail.

I do not know how to explain it.  My assumption is that my ISP (Verizon DSL) finallyact ed on my complaints of slow internet access and frequent service interrupts and that whatever they did also resolved the email problems.  I did not include these perceived difficulties with my ISP in my original trouble ticket because the ISP problem has been going on for a very long time and Verizon consistently denied any trouble on their part.

My telephone as well as the internet access completely stopped recently.  The repair person said that my line was old and broke at the substation and it was replaced by a "stronger line".  So maybe the line was the problem all along...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.