Open Bug 694248 Opened 9 years ago Updated 4 years ago

Intermittent Android layout/tables/crashtests/691824-1.xhtml | load failed: null

Categories

(Core :: Layout: Tables, defect, P3)

ARM
Android
defect

Tracking

()

REOPENED

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

(Could have been more before this, I usually ignore these because they're usually a different one every time and once a week, not multiple per day of the same one.)

https://tbpl.mozilla.org/php/getParsedLog.php?id=6820452&tree=Mozilla-Inbound
Android Tegra 250 mozilla-inbound opt test crashtest on 2011-10-12 16:17:41 PDT for push 78b48c64903c

REFTEST TEST-START | http://10.250.48.200:30023/tests/layout/tables/crashtests/691824-1.xhtml | 1653 / 1945 (84%)
failed to validate file when downloading /mnt/sdcard/tests/reftest/reftest.log!
failed to validate file when downloading /mnt/sdcard/tests/reftest/reftest.log!
REFTEST TEST-UNEXPECTED-FAIL | http://10.250.48.200:30023/tests/layout/tables/crashtests/691824-1.xhtml | load failed: null
REFTEST INFO | Saved log: START http://10.250.48.200:30023/tests/layout/tables/crashtests/691824-1.xhtml

The "failed to validate" noise, which looks like it would mean something, is as I understand it nothing but pure noise, where the controller thought something should have happened since the last time it peeked at the pot to see if it was boiling yet, but it wasn't boiling yet, so it says that it looked but it wasn't boiling yet in the most alarming way it can.
Could it be that the file is just taking too long to load?  It loads instantly on desktop Firefox, but I can't think of anything else, since I haven't seen the "load failed: null" message that often...
Attached patch skip-ifSplinter Review
We're not learning anything here.
Attachment #590907 - Flags: review?(ehsan)
Well, we're learning that adding the native Fennec crashtests more than doubled the instances, probably more like quintupled, but we're not learning anything *interesting* here.
Comment on attachment 590907 [details] [diff] [review]
skip-if

r=me.
Attachment #590907 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/d46d4d740529
Whiteboard: [orange] → [orange][please leave open]
Whiteboard: [orange][please leave open] → [orange][skipped starting with Mozilla12]
Whiteboard: [orange][skipped starting with Mozilla12] → [orange][test disabled on android]
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 789751
Given the hundreds here and the singles in all the other dupes, I think this is the exception where there's actually something about a particular test.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [orange][test disabled on android] → [test disabled on android]
Test runs without issue on Android now.
Status: REOPENED → RESOLVED
Closed: 8 years ago5 years ago
Flags: in-testsuite+
Resolution: --- → WORKSFORME
Whiteboard: [test disabled on android]
removing the b2g 2.5 flag since this commit has been reverted due to an incorrect merge, sorry for the confusion
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.