Cannot allow pop-ups for a site (allow popups appears ineffective)

UNCONFIRMED
Unassigned

Status

()

Firefox
Preferences
UNCONFIRMED
7 years ago
2 years ago

People

(Reporter: Patrick Finch, Unassigned)

Tracking

9 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
I don't think that this is a duplicate of bug 356377, having read through, although it may be related. 

I have created an exception for a site to allow popups, and still, Aurora seems to continue to block the popup.  The message updates at every attempt, "Aurora prevented this site form opening x pop-up windows." and a dialogue appears "Error creating window".  After 5 attempts, the dialogue changes to offer also the preference "Prevent this site from creating additional dialogs".  

If I reload, the count goes back to zero, but still no popup.

Example site is http://www.firstmusic.nu/ - this worked in previous versions for me.
(Reporter)

Comment 1

7 years ago
Created attachment 571008 [details]
Aurora preventing a popup after user has allowed it

Attaching a screenshot which illustrates the problem.  I've already accepted popups from this site (Aurora now offers to Block them again), but at the same time, Aurora is telling me that it prevented this site from opening a pop-up window.

Comment 2

7 years ago
Tested this with a clean profile running Aurora and I can't reproduce the problem on gmail.com or popuptest.com. There must be something else going on in your profile.
Status: NEW → UNCONFIRMED
Ever confirmed: false

Comment 3

2 years ago
Created attachment 8760019 [details]
Gmail-Amazon-Tracking-Link-Popup-error.png

I am having the same problem on Gmail, and I believe I have identified the cause of the problem (at least the way it manifests for me).

I have an e-mail in my inbox from Amazon.ca. The email contains a tracking link for my package. 

Gmail automatically shows in my inbox a button "Track Package ->" at the right end of the subject line for that message (see screenshot in attachment), so I can track the package without having to open the e-mail. (A pretty boss feature, if you ask me!) 

When I click on the "Track Package", I get a popup error. It offers the option to "Show https://mail.google.com/mail/u/0" which just opens the inbox again.

When I click on "Edit Pop-up Blocker Preferences...", it autofills mail.google.com in the field to add this site to the whitelist.

The problem is that the url is https://mail.google.com, but the whitelist adds it as http://mail.google.com. It took me a lot of tries (e.g. various amazon varieties) to figure this out. The workaround is to manually type in the https:// into the whitelist suggestion.

I suggest that if the user is viewing a site in the https:// variant of the URL, that FF should include that in the suggestion, instead of stripping it off.

- RG>
You need to log in before you can comment on or make changes to this bug.