Last Comment Bug 694298 - Changing SVG text to empty doesn't repaint
: Changing SVG text to empty doesn't repaint
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla10
Assigned To: Robert Longson
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 655025
  Show dependency treegraph
 
Reported: 2011-10-13 06:01 PDT by Patrick R. Gansterer
Modified: 2011-10-15 05:39 PDT (History)
2 users (show)
longsonr: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (251 bytes, image/svg+xml)
2011-10-13 06:01 PDT, Patrick R. Gansterer
no flags Details
patch (2.50 KB, patch)
2011-10-13 07:04 PDT, Robert Longson
dholbert: review+
Details | Diff | Splinter Review
with the right reftest this time (2.78 KB, patch)
2011-10-14 05:32 PDT, Robert Longson
no flags Details | Diff | Splinter Review

Description Patrick R. Gansterer 2011-10-13 06:01:59 PDT
Created attachment 566792 [details]
Testcase
Comment 1 Robert Longson 2011-10-13 07:04:02 PDT
Created attachment 566805 [details] [diff] [review]
patch

We now skip glyph frames that don't contain any text when we layout the text. Of course if the glyph did once contain text and now doesn't then we end up skipping clearing it.
Comment 2 Daniel Holbert [:dholbert] 2011-10-13 11:06:36 PDT
Comment on attachment 566805 [details] [diff] [review]
patch

>diff --git a/layout/reftests/svg/reftest.list b/layout/reftests/svg/reftest.list
>+== dynamic-text-05.svg pass.svg

>diff --git a/layout/reftests/svg/script-empty-01.svg b/layout/reftests/svg/script-empty-01.svg
[...]
>+  <title>Testcase for that xlink:href attribute overrides script content</title>

Looks like you |hg add|'ed the wrong test file.  (dynamic-text-05 vs script-empty-01.svg

r=me with that fixed. (I'll trust that dynamic-text-05.svg is sane. :) )
Comment 3 Robert Longson 2011-10-14 05:32:01 PDT
Created attachment 567060 [details] [diff] [review]
with the right reftest this time
Comment 5 Ed Morley [:emorley] 2011-10-15 05:39:07 PDT
https://hg.mozilla.org/mozilla-central/rev/de59e7adc9f6

Note You need to log in before you can comment on or make changes to this bug.