Note: There are a few cases of duplicates in user autocompletion which are being worked on.

[c-c] "Warning: package error or possible missing or unnecessary file:" : 4 "VC80" files. (WIN32_REDIST_DIR is needed again.)

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Build Config
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sgautherie, Assigned: Callek)

Tracking

Trunk
Thunderbird 13.0
x86
Windows Server 2003
Dependency tree / graph
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.6- wontfix, seamonkey2.7- wontfix, seamonkey2.8 fixed, seamonkey2.9 fixed)

Details

(Whiteboard: [fixed in comm10a1: Bv1, SMv2.8a1: Av1-SM, SMv2.10a1: WIN32_REDIST_DIR])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
In addition to (FF) bug 694353, SeaMonkey has the following warnings:

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1318429599.1318448919.16271.gz
WINNT 5.2 comm-central-trunk build on 2011/10/12 07:26:39
{
Warning: package error or possible missing or unnecessary file: bin/Microsoft.VC80.CRT.manifest (package-manifest, 45).
Warning: package error or possible missing or unnecessary file: bin/msvcm80.dll (package-manifest, 46).
Warning: package error or possible missing or unnecessary file: bin/msvcp80.dll (package-manifest, 47).
Warning: package error or possible missing or unnecessary file: bin/msvcr80.dll (package-manifest, 48).
}

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1315926742.1315943040.15790.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2011/09/13 08:12:22
already had this bug.

***

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1318446822.1318464400.17544.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/10/12 12:13:42
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1317275406.1317286128.26055.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/28 22:50:06
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1317184843.1317202181.6362.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/27 21:40:43
rev:0a289bc5e5ea
moz:91108b393572
already had this bug.

http://hg.mozilla.org/releases/comm-aurora/pushloghtml?fromchange=82bbc61f708b&tochange=0a289bc5e5ea
(big) Merge from comm-central :-/
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=9b32a50de895&tochange=91108b393572
(huge) Merge from mozilla-central :-/
Searching for "MSVC", I'm guessing at bug 678161 or the like.
Mike, could you confirm ?

(2 red builds in-between)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1317051655.1317060069.6921.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/26 08:40:55
rev:82bbc61f708b
moz:9b32a50de895
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1317024198.1317038300.26629.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/26 01:03:18
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1316622260.1316636019.27612.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/21 09:24:20
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Aurora/1315949173.1315963663.10027.gz&fulltext=1
WINNT 5.2 comm-aurora build on 2011/09/13 14:26:13
didn't have this bug.

***

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey-Beta/1318385590.1318397671.23631.gz&fulltext=1
WINNT 5.2 comm-beta build on 2011/10/11 19:13:10
doesn't have this bug.
Flags: in-testsuite-
Yes, that and the subsequent jemalloc/mozutils related changes.
(Reporter)

Comment 2

6 years ago
Hum, another changeset without a bug number :-/
{
bugzilla@standard8.plus.com
Thu Aug 25 12:14:41 2011 -0700
http://hg.mozilla.org/comm-central/rev/eebfdbc18e61
Port bug 678161, bug 673197, bug 678195 to fix windows bustage - fix SeaMonkey manifests. rs=Callek
}

From what I've seen so far:
bug 678161 and bug 681893 are what I had started to look at.
I was going to look at bug 678195 too.
I'll have to look how bug 673197 fits in.
Assignee: nobody → sgautherie.bz
Status: NEW → ASSIGNED
Depends on: 673197, 678195
(Reporter)

Comment 3

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> Hum, another changeset without a bug number :-/

Oh, that was actually a follow-up to another similar changeset :-/
{
bugzilla@standard8.plus.com
Thu Aug 25 04:46:43 2011 -0700
http://hg.mozilla.org/comm-central/rev/fb9e7f177a7e
Port bug 678161, bug 673197, bug 678195 to fix windows bustage. r=bustage-fix for CLOSED TREE
}
(Reporter)

Comment 4

6 years ago
Created attachment 568694 [details] [diff] [review]
(Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
[Checked in: Comment 14]

This way is simpler and prepares for adding VC 11 support.
Attachment #568694 - Flags: review?
(Reporter)

Updated

6 years ago
Attachment #568694 - Flags: review?(kairo)
Attachment #568694 - Flags: review?(bugspam.Callek)
Attachment #568694 - Flags: review?
(Reporter)

Updated

6 years ago
Attachment #568694 - Attachment description: Bug 694371. (Av1-SM) removed-files.in: Use != instead of ==. (as in m-c bug 681893) → (Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
(Reporter)

Updated

6 years ago
Depends on: 681893
(Reporter)

Updated

6 years ago
Depends on: 696422
(Reporter)

Comment 5

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> bug 678161 and bug 681893 are what I had started to look at.

Port of these bugs looks fine (with filed "Core" bug 696422).
(Reporter)

Comment 6

6 years ago
Created attachment 568717 [details] [diff] [review]
(Bv1) autoconf.mk.in: Remove leftover WIN32_CRT_SRC_DIR from bug 678195 port
[Checked in: Comment 10]

Trivial missed cleanup.
Attachment #568717 - Flags: review?(mbanner)
(Reporter)

Comment 7

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #2)

> I was going to look at bug 678195 too.

Port of this bug looks fine (with attached patch Bv1).

> I'll have to look how bug 673197 fits in.

Port of this bug looks fine.

***

I need to continue searching...
Comment on attachment 568717 [details] [diff] [review]
(Bv1) autoconf.mk.in: Remove leftover WIN32_CRT_SRC_DIR from bug 678195 port
[Checked in: Comment 10]

r=me though I'd really prefer these on a mailnews core bug, and its only vaguely related tovthis bug.
Attachment #568717 - Flags: review?(mbanner) → review+
(Reporter)

Comment 9

6 years ago
Thunderbird has this bug too:

http://tinderbox.mozilla.org/showlog.cgi?log=ThunderbirdTrunk/1319234499.1319259055.25890.gz&fulltext=1
WINNT 5.2 comm-central build on 2011/10/21 15:01:39
{
Warning: package error or possible missing or unnecessary file: bin/Microsoft.VC80.CRT.manifest (package-manifest, 29).
Warning: package error or possible missing or unnecessary file: bin/msvcm80.dll (package-manifest, 30).
Warning: package error or possible missing or unnecessary file: bin/msvcp80.dll (package-manifest, 31).
Warning: package error or possible missing or unnecessary file: bin/msvcr80.dll (package-manifest, 32).
}
Component: Build Config → Build Config
Product: SeaMonkey → MailNews Core
QA Contact: build-config → build-config
Summary: "Warning: package error or possible missing or unnecessary file:" : 4 "VC80" files → [c-c] "Warning: package error or possible missing or unnecessary file:" : 4 "VC80" files
(Reporter)

Comment 10

6 years ago
Comment on attachment 568717 [details] [diff] [review]
(Bv1) autoconf.mk.in: Remove leftover WIN32_CRT_SRC_DIR from bug 678195 port
[Checked in: Comment 10]

http://hg.mozilla.org/comm-central/rev/543d72f7ebf5
Attachment #568717 - Attachment description: (Bv1) autoconf.mk.in: Remove leftover WIN32_CRT_SRC_DIR from bug 678195 port → (Bv1) autoconf.mk.in: Remove leftover WIN32_CRT_SRC_DIR from bug 678195 port [Checked in: Comment 10]
(Reporter)

Comment 11

6 years ago
Comment on attachment 568694 [details] [diff] [review]
(Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
[Checked in: Comment 14]

Callek (or KaiRo), ping for review.

Comment 12

6 years ago
Comment on attachment 568694 [details] [diff] [review]
(Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
[Checked in: Comment 14]

Review of attachment 568694 [details] [diff] [review]:
-----------------------------------------------------------------

I'll leave this one to Callek as I'm pretty much out of the loop on what we are doing for MSVC runtime libraries nowadays, and what we'll need with the switch to MSVC2010 coming along.
Attachment #568694 - Flags: review?(kairo)
(Assignee)

Comment 13

6 years ago
Comment on attachment 568694 [details] [diff] [review]
(Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
[Checked in: Comment 14]

Sorry for the delay serge, looks good!

While you're here, rs+ for the block for MSVC11 (#if _MSC_VER != 1700)
Attachment #568694 - Flags: review?(bugspam.Callek) → review+
(Reporter)

Comment 14

6 years ago
Comment on attachment 568694 [details] [diff] [review]
(Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of ==
[Checked in: Comment 14]

http://hg.mozilla.org/comm-central/rev/5e2c9c9d03b5


(In reply to Justin Wood (:Callek) from comment #13)
> While you're here, rs+ for the block for MSVC11 (#if _MSC_VER != 1700)

Done in bug 707021.
(Reporter)

Updated

6 years ago
Attachment #568694 - Attachment description: (Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of == → (Av1-SM) removed-files.in: Use != (as in m-c bug 681893) instead of == [Checked in: Comment 14]
(Reporter)

Comment 15

6 years ago
Ah, I checked a bunch of SeaMonkey trunk logs for Win_opt and Win_nightly.

It looks like this could be affecting (only) some "builders":
at first glance, it would look like
*cb-sea-win32-tbox (nightly) was fixed after 23_17h and before 30_06h.
*cb-seamonkey-win32-0[123] are fine.
*cn-sea-qm-win2k3-01 (both) is still affected.

Let's check whether a clobber fixes this bug: I requested it
for cn-sea-qm-win2k3-01 'build' and 'nightly' on 2011-12-02 17:33:29 PST...
(Reporter)

Comment 16

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #15)
> Let's check whether a clobber fixes this bug: I requested it
> for cn-sea-qm-win2k3-01 'build' and 'nightly' on 2011-12-02 17:33:29 PST...

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1322888359.1322903828.31207.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2011/12/02 20:59:19
{
Building on: cn-sea-qm-win2k3-01

comm-cen-trunk-w32:Our last clobber date:  2011-12-02 17:33:29
comm-cen-trunk-w32:Server clobber date:    2011-12-02 17:33:29
comm-cen-trunk-w32-ntly:Our last clobber date:  2011-12-02 17:33:29
comm-cen-trunk-w32-ntly:Server clobber date:    2011-12-02 17:33:29

[Bug still there]
}

Iiuc, cloberring action is not explicitly noted anywhere (and there was no other build on this builder in the meantime.
Callek, was clobber actually done? How can "I" know that? Can you check it?
If clobber did happen, then I would assume this builder(s) is somehow misconfigured... Can you check that?
Severity: normal → major
Keywords: helpwanted
Whiteboard: [ToDo: comment 16 (for SM)]
(Assignee)

Comment 17

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #16)
> Iiuc, cloberring action is not explicitly noted anywhere (and there was no
> other build on this builder in the meantime.
> Callek, was clobber actually done? How can "I" know that? Can you check it?
> If clobber did happen, then I would assume this builder(s) is somehow
> misconfigured... Can you check that?

I know I won't be able to check that builder by our last 2.6 build. Sorry.
tracking-seamonkey2.6: ? → -
(Reporter)

Updated

6 years ago
Blocks: 713134, 713133
No longer depends on: 515374, 526333
No longer blocks: 713133
(Reporter)

Comment 18

6 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey/1325395137.1325414342.5676.gz&fulltext=1
WINNT 5.2 comm-central-trunk build on 2011/12/31 21:18:57
s: cb-sea-win32-tbox

(still) has this bug (too).
(Reporter)

Comment 19

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #18)
> s: cb-sea-win32-tbox
> 
> (still) has this bug (too).

I'm not sure whether this case is an old or new error.

***

(Mark,) It looks like SeaMonkey needs to port TB bug 712960, doesn't it?
(Justin,) Or would bug 714495 (or the like) supersede bug 712960 (and the current one)?
(Assignee)

Comment 20

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #19)
> (In reply to Serge Gautherie (:sgautherie) from comment #18)
> > s: cb-sea-win32-tbox
> > 
> > (still) has this bug (too).
> 
> I'm not sure whether this case is an old or new error.
> 
> ***
> 
> (Mark,) It looks like SeaMonkey needs to port TB bug 712960, doesn't it?

No we don't, we just need to make sure that we export that data the same way as our other win32 boxes.

> (Justin,) Or would bug 714495 (or the like) supersede bug 712960 (and the
> current one)?

That bug is a different issue.
(Reporter)

Updated

6 years ago
Whiteboard: [ToDo: comment 16 (for SM)] → [ToDo: comment 16+20 (for SM)]
(Reporter)

Comment 21

6 years ago
(In reply to Justin Wood (:Callek) from comment #17)
> I know I won't be able to check that builder by our last 2.6 build. Sorry.

/pub/mozilla.org/seamonkey/releases/2.6/win32/en-US
seamonkey-2.6.zip
/pub/mozilla.org/seamonkey/releases/2.6.1/win32/en-US
seamonkey-2.6.1.zip

both include these 4 files :-)
(Hopefully, we were safe for all locales of these releases.)
(Reporter)

Comment 22

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> http://hg.mozilla.org/comm-central/rev/eebfdbc18e61
> Port bug 678161, bug 673197, bug 678195 to fix windows bustage - fix
> SeaMonkey manifests. rs=Callek

(In reply to Justin Wood (:Callek) from comment #20)
> (In reply to Serge Gautherie (:sgautherie) from comment #19)
> > (Mark,) It looks like SeaMonkey needs to port TB bug 712960, doesn't it?
> 
> No we don't, we just need to make sure that we export that data the same way
> as our other win32 boxes.

Ftr,
https://developer.mozilla.org/en/Windows_Build_Prerequisites#section_10
{
If you intend to distribute your build to others, and you have not built with --enable-jemalloc, you will need to set WIN32_REDIST_DIR=$VCINSTALLDIR\redist\x86\Microsoft.VC80.CRT in your mozconfig to get the Microsoft CRT DLLs packaged along with the application.
}
though, per bug 712960, that may (now) be needed even with --enable-jemalloc.
(See comment 2 quoted changeset.)

***

Mike, that DMO page needs updating, right?
(In reply to Serge Gautherie (:sgautherie) from comment #22)
> Mike, that DMO page needs updating, right?

Indeed. I updated it.
(Reporter)

Comment 24

6 years ago
(In reply to Mike Hommey [:glandium] from comment #23)
> (In reply to Serge Gautherie (:sgautherie) from comment #22)
> > Mike, that DMO page needs updating, right?
> 
> Indeed. I updated it.

Thanks, I restored old case (ftr), so it now reads:
{
If you intend to distribute your build to others, you will need to set WIN32_REDIST_DIR=$VCINSTALLDIR\redist\x86\Microsoft.VC80.CRT in your mozconfig to get the Microsoft CRT DLLs packaged along with the application.
    * Prior to Gecko 9 (FF 9, SM 2.6, TB 9) , this was needed only if you had not built with --enable-jemalloc.
}
Depends on: 712960
Whiteboard: [ToDo: comment 16+20 (for SM)] → [ToDo: comment 16+22 (for SM)]
(Reporter)

Updated

6 years ago
Depends on: 718323
(Reporter)

Updated

6 years ago
Depends on: 712528
No longer depends on: 718323
Summary: [c-c] "Warning: package error or possible missing or unnecessary file:" : 4 "VC80" files → [c-c] "Warning: package error or possible missing or unnecessary file:" : 4 "VC80" files. (WIN32_REDIST_DIR is needed again.)
(Reporter)

Comment 25

6 years ago
http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=3097e9c39214

This bug is not reproducible on MoMe Try as the latter defines WIN32_REDIST_DIR (on opt builds).

All other (real) blockers of SM bug 713134 have patches (to review) now.

*****

(In reply to Justin Wood (:Callek) from comment #20)
> (In reply to Serge Gautherie (:sgautherie) from comment #19)
> > (Mark,) It looks like SeaMonkey needs to port TB bug 712960, doesn't it?
> 
> No we don't, we just need to make sure that we export that data the same way
> as our other win32 boxes.

http://mxr.mozilla.org/build/search?string=WIN32_REDIST_DIR&case=on
'thunderbird/win32', 'mozilla2/win32-mobile' and 'mozilla2/mobile/win32-i686' do it from their 'nightly' and 'release' mozconfigs.

Other builds (like Firefox) must do it otherwise. (Set in Windows environment? Or in a script?)
(Assignee)

Updated

6 years ago
tracking-seamonkey2.7: ? → -
(Reporter)

Updated

6 years ago
status-seamonkey2.6: --- → wontfix
status-seamonkey2.7: --- → affected
status-seamonkey2.8: --- → affected
tracking-seamonkey2.8: --- → ?
(Reporter)

Comment 26

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #25)
> All other (real) blockers of SM bug 713134 have patches (to review) now.

There are all fixed atm. Blocked by this bug only now...
(Reporter)

Comment 27

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #21)

> /pub/mozilla.org/seamonkey/releases/2.6.1/win32/en-US
> seamonkey-2.6.1.zip

and
/pub/mozilla.org/seamonkey/releases/2.7/win32/en-US
seamonkey-2.7.zip

> both include these 4 files :-)
> (Hopefully, we were safe for all locales of these releases.)
status-seamonkey2.9: --- → affected
(Reporter)

Comment 28

6 years ago
(In reply to Serge Gautherie (:sgautherie) from comment #27)
> /pub/mozilla.org/seamonkey/releases/2.7/win32/en-US
> seamonkey-2.7.zip

and
/pub/mozilla.org/seamonkey/releases/2.7.1/win32/en-US
seamonkey-2.7.1.zip

> > both include these 4 files :-)
> > (Hopefully, we were safe for all locales of these releases.)
(Reporter)

Comment 29

6 years ago
/mozilla.org/seamonkey/releases/2.7.2/win32/en-US
seamonkey-2.7.2.zip
includes these 4 files :-)
(Assignee)

Comment 30

6 years ago
Fixed up:

cb-sea-win32-tbox
cn-sea-qm-win2k3-01

They need to actually reboot before this fix goes into affect, but they should within the day.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Assignee: sgautherie.bz → bugspam.Callek
(Reporter)

Updated

6 years ago
status-seamonkey2.7: affected → wontfix
status-seamonkey2.8: affected → fixed
status-seamonkey2.9: affected → fixed
tracking-seamonkey2.8: ? → ---
Keywords: helpwanted
Whiteboard: [ToDo: comment 16+22 (for SM)] → [fixed in comm10a1: Bv1, SMv2.8a1: Av1-SM, SMv2.10a1: WIN32_REDIST_DIR]
Target Milestone: --- → Thunderbird 13.0
You need to log in before you can comment on or make changes to this bug.