Firefox will not play .NSC (multicast) files through Silverlight

RESOLVED WONTFIX

Status

()

Core
Plug-ins
RESOLVED WONTFIX
7 years ago
a year ago

People

(Reporter: Greg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; TEIS-8-20091005.1; .NET4.0C; .NET4.0E; InfoPath.3; MS-RTC LM 8)

Steps to reproduce:

I have a multicast file that is hosted on a webserver and i'm trying to invoke from Firefox. The file will not play in Windows Media Player.  This has been a problem since FF 3.6.4.

The file reference looks like this: http://windowsmediaserver.domain.com/multicasttest/MulticastTest.nsc


Actual results:

When i load this path, Firefox prompts me to "open with" and correctly identifies Windows Media Player as the default.  I click "ok" to continue and when Windows Media Player opens, i get an error message that this file can't be opened.


Expected results:

Like IE8, the file should have opened either directly in Windows Media Player or after "open with" window and choosing the player and then selecting "always do with this type of file" it should have launched and played.

What i have found is that in the Windows Media Playlist the file has a name of: MulticastTest.nsc-3 and when i then go to the location of this Temp file i can see that the actual file name has been renamed to MulticastTest.nsc-3.asx when it should be MulticastTest.nsc as this is the actual file name and can be read by Windows Media Player.

I have also posted some detail on this bug reference:  https://bugzilla.mozilla.org/show_bug.cgi?id=610434

Thank you,
Greg Jones
(Reporter)

Comment 1

7 years ago
I actually created both an .asx file and .nsc file for the multicast stream.  The .asx file launched and played perfectly.  It appears that .nsc files want to be saved locally as .asx (but this is not valid) in the use of the .nsc file.  It appears that Firefox should be configured to honor the .nsc file and just make the request leaving the extension alone.
(Reporter)

Comment 2

7 years ago
To follow up on my previous post about creating both the .asx and .nsc files.  I want to be clear on what did work and did not work.

In Windows Media Server i created both an output .asx and .nsc file for my multicast publishing point.  When i reference the full path to the .nsc file, i get the reported error above about the .nsc file being renamed with a .asx on the end - and Windows Media Player will not play this because it isn't valid as the file doesn't really exist (multicast.nsc is the real name but Firefox renames to multicast.nsc.asx).  When i hit the full path to the asx. file that i created when announcing my publishing point - http://servername/muticast.asx - firefox launches Windows Media Player and then WMP launches this play list and goes and fetches the embedded URL for the .nsc file perfectly.

What breaks, is when i have silverlight on my page and in the player i make a call to launch the .nsc file - this fails as noted by rename of .nsc file.  And calling http://servername/multicast.asx file also fails because the browser then appears to try and connect to the playlist embeded URL which is the .nsc file and i'm back to it renaming the file and that will never work!

This is the problem...firefox, is renaming .nsc files and appending .asx to it... so you get "filename.nsc.asx" - not valid.

Again, this has been a bug since 3.6.4 roughly and is still the case in 7.0.1.

Thanks,
Greg Jones
Please attach a http log: https://developer.mozilla.org/en/HTTP_Logging (use NSPR_LOG_MODULES=nsHttp:5)

Comment 4

6 years ago
Reporter, do you still see this problem?
Whiteboard: closeme INCO 2012-07-01
(Reporter)

Comment 5

6 years ago
Yes, this is still an issue.  We are unable to play Windows Media .NSC (Multicast) files via silverlight v4 and v5 in Firfox.  I have attached a log file.  The page will load but the Silverlight player will remain empty and will never show buffering content - the video never plays.
(Reporter)

Comment 6

6 years ago
Created attachment 631354 [details]
Log file at requested

Attached log file by setting up the pc to log the requests.
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Whiteboard: closeme INCO 2012-07-01
Version: 3.6 Branch → unspecified
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.