Setup: Installer stub appears to not be internationalized as Japanese characters do not display correctly.

VERIFIED FIXED

Status

()

Core
Internationalization
P4
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Wesley George, Assigned: Ying-Lin Xia)

Tracking

({intl})

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
<summary>
Setup: Japanese DBCS folder name is garbled when selected for destination 
directory. 

<repro environment>
build 02-19-06 + Win98-JA

<repro steps>
1. create a directory with Japanese DBCS
2. launch setup, advance to the third setup screen
3. click Browse and select the directory created in step #1

<result>
Japanese DBCS characters are mojibake (garbled)
(Reporter)

Comment 1

18 years ago
Created attachment 25681 [details]
reference image

Comment 2

18 years ago
Did the set up succeed after the display problem?
Summary: Setup: Japanese DBCS folder name is garbled when selected for destination directory. → Setup: Japanese DBCS folder name is garbled when selected for destination directory.
(Reporter)

Comment 3

18 years ago
Yes.

Comment 4

18 years ago
Changed QA contact to ylong@netscape.com.
Keywords: intl
QA Contact: teruko → ylong

Comment 5

18 years ago
Reassign to the default owner of installer.
Can installer use xpcom (e.g. nsILocalFile)?

Assignee: nhotta → ssu
Priority: -- → P4

Comment 6

18 years ago
nope, because xpcom is unavailable at that point.  It hasn't been downloaded yet.
Status: NEW → ASSIGNED

Comment 7

18 years ago
this looks pretty bad. the installer is the customer's first experience with our
product, and this would not leeave them with a good taste.

i know this is probably hard to fix, but i respectfully request nsbeta1, and
target milestone as M0.9.1

Yuying - Is this across all platforms?
Keywords: nsbeta1

Comment 8

18 years ago
I saw this on both WindowsME-Ja and Linux RH6.2-Ja but Mac-Ja. Change platform 
to All.  cc: jonrubin
OS: Windows 98 → All
Hardware: Other → All

Comment 9

18 years ago
In the "Select a directory" window, if a new directory name is entered such that 
the "Create Directory?" dialogue pops up, a Japanese folder-name displays 
correctly in this dialogue.  But back in the "Setup Type" window, the new 
Japanese folder-name appears as garbage characters.

If the Custom Install option is selected, one of the last setup windows is the 
"Select Program Folder" window; both the "Program Folder" and "Existing Folders" 
fields do not display Japanese characters correctly.

The last two windows, "Download Options" and "Start Install" also do not display 
Japanese characters correctly; specifically, the "Save installer files locally" 
and the "Current Settings" fields are affected.  These issues seem to be limited 
to the installer itself; Japanese folder names do get created correctly, and the 
setup does succeed.

In view of all of these issues, I would like to suggest renaming this bug from 
"Setup: Japanese DBCS 
folder name is garbled when selected for destination directory." to "Setup: 
Installer stub appears to not be internationalized as Japanese characters do not 
display correctly."

I respectfully nominate this bug for nscatfood, priority P2, and target 
milestone as M0.9.1

Comment 10

18 years ago
Changing QA contact to jonrubin@netscape.com, updating summary field to better 
reflect the problem and nominating this bug for nsCatFood.
Keywords: nsCatFood
QA Contact: ylong → jonrubin
Summary: Setup: Japanese DBCS folder name is garbled when selected for destination directory. → Setup: Installer stub appears to not be internationalized as Japanese characters do not display correctly.

Comment 11

18 years ago
I'll take a look at it and see what I come up with.
Keywords: mozilla0.9.1
(Assignee)

Comment 12

18 years ago
ssu, this is fixed already with my patch in Bug 42904.

Comment 13

18 years ago
I thought you had something that had fixed this.  Marking this bug dependent on 
bug 42904.
Depends on: 42904

Comment 14

18 years ago
Not reproduce on lastest trunk build Linux installer, change to Win32.
OS: All → Windows ME
Hardware: All → PC

Comment 15

18 years ago
[testing my permissions--please disregard]
Summary: Setup: Installer stub appears to not be internationalized as Japanese characters do not display correctly. → Setup: Installer stub appears to not be internationalized as Japanese characters are not display correctly.

Comment 16

18 years ago
[testing my permissions (completed)--please disregard]
Summary: Setup: Installer stub appears to not be internationalized as Japanese characters are not display correctly. → Setup: Installer stub appears to not be internationalized as Japanese characters do not display correctly.

Updated

18 years ago
No longer depends on: 42904

Comment 17

17 years ago
marking this fixed since yxia said his patch to bug 42904 fixes this.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Depends on: 42904
Resolution: --- → FIXED

Comment 18

17 years ago
Jon, please verify that patch to bug 42904 fixes this problem.

Comment 19

17 years ago
Verified on build 05-04-06 trunk on WinME-Ja.  Note that there is now a problem 
of truncated text in the last "Start Install" window, as described in bug # 
79173.
Status: RESOLVED → VERIFIED

Comment 20

17 years ago
Todd Pringle is reporting a problem with the en language installers now which 
might be due to this fix.  Adding tpringle and loeb to the CC: list.

Comment 21

17 years ago
Yes, with the adoption of system fonts, some of the installer dialogs become
unreadable/get smashed depending on which fonts you're using.  This makes the
installation experience a very bad one for those users.

Comment 22

17 years ago
This looks like it is fixed, right?

Comment 23

17 years ago
Created attachment 34760 [details]
Install screen with adopted system fonts

Comment 24

17 years ago
No, what I am saying is that by fixing this bug, we've created another
potentially worse problem.
(Assignee)

Comment 25

17 years ago
Sean, another idea is to put the font name into the install.ini file, so we can 
define different font for the different language.
(Assignee)

Comment 26

17 years ago
But, in that case, this bug will come back, cause the en installer won't show 
Japanese character properly again.

Comment 27

17 years ago
I've opened a bug on the new issue: bug 81248
Please add comments to that bug instead of this one.  This bug is closed and 
verified.

Comment 28

17 years ago
This problems still occurs on Linux RH6.2-Ja.  Checked using 2001052205 
Installer build.  If I create a folder with a Japanese name and then start the 
Installer, I cannot display Japanese characters correctly in the "Select a 
Directory" and "Netscape Installer" windows.  In "Select a Directory", the 
"Directories" and "Selection" fields do not display the Japanese folder 
correctly.  In "Netscape Installer", the "Destination Directory" does not 
display Japanese correctly.

As this is currently not a problem in WinMe (as originally reported) or Mac, I'm 
changing the OS to Linux.

Status: VERIFIED → REOPENED
OS: Windows ME → Linux
Resolution: FIXED → ---

Comment 29

17 years ago
Ying, did you do any work on this for linux before, or is this something new?
Assignee: ssu → yxia
Status: REOPENED → NEW
(Assignee)

Comment 30

17 years ago
No, Sean, I only did the Mac and Win32 installer i18n issue for bug 42902 and 
bug 42904, and it's done. No more updates for now.

And also, jonrubin, please file different bugs for Linux installer, cause the 
installer source code is cross-platform. And please assign to sgehani.

Comment 31

17 years ago
Reassigning this to sgehani.  Ying, do we really need a separate bug for this?  
The description of the problem is the same.
Assignee: yxia → sgehani
(Assignee)

Comment 32

17 years ago
Well, I think we do. For any installer bug, we will need different patch for 
different platform. To avoid any confusion, we need to file different bugs, 
even with same description.

Comment 33

17 years ago
Created bug 83353 for this problem on Linux.  Resetting OS of this bug to Win98 
and assigning back to yxia to avoid confusion with 83353.  This bug is fixed as 
far as Win32 and Mac are concerned.
Assignee: sgehani → yxia
OS: Linux → Windows 98
(Assignee)

Comment 34

17 years ago
Change to FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 35

17 years ago
Verified as per my comments on 2001-05-07 15:40.  See bug 83353 for this problem 
on Linux.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.