Uploading XPIs causes 500 error.

RESOLVED DUPLICATE of bug 694474

Status

addons.mozilla.org Graveyard
Developer Pages
--
critical
RESOLVED DUPLICATE of bug 694474
6 years ago
2 years ago

People

(Reporter: kmag, Unassigned)

Tracking

Details

Uploading XPIs either to the standalone validator or as standard add-on submissions or update fails with the following error:

  Received an empty response from the server; status: 500

I've tried several unrelated XPIs from different authors and all appear to be the same. Preview is unaffected.

Comment 1

6 years ago
Traceback (most recent call last):

 File "/data/www/addons.mozilla.org/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/www/addons.mozilla.org/zamboni/apps/amo/decorators.py", line 102, in wrapper
   return f(*args, **kw)

 File "/data/www/addons.mozilla.org/zamboni/apps/amo/decorators.py", line 94, in wrapper
   return f(*args, **kw)

 File "/data/www/addons.mozilla.org/zamboni/apps/amo/decorators.py", line 28, in wrapper
   return func(request, *args, **kw)

 File "/data/www/addons.mozilla.org/zamboni/apps/amo/decorators.py", line 49, in wrapper
   return f(request, *args, **kw)

 File "/data/www/addons.mozilla.org/zamboni/apps/devhub/views.py", line 634, in upload
   tasks.validator.delay(fu.pk)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/task/base.py", line 338, in delay
   return self.apply_async(args, kwargs)

 File "/data/www/addons.mozilla.org/zamboni/vendor/src/nuggets/celeryutils.py", line 22, in apply_async
   return super(Task, self).apply_async(args, kwargs, **options)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/task/base.py", line 448, in apply_async
   exchange_type=exchange_type)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/task/base.py", line 301, in get_publisher
   **options)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/app/amqp.py", line 328, in TaskPublisher
   return TaskPublisher(*args, **self.app.merge(defaults, kwargs))

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/celery/app/amqp.py", line 156, in __init__
   super(TaskPublisher, self).__init__(*args, **kwargs)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/compat.py", line 79, in __init__
   self.backend = connection.channel()

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/connection.py", line 124, in channel
   chan = self.transport.create_channel(self.connection)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/connection.py", line 439, in connection
   self._connection = self._establish_connection()

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/connection.py", line 405, in _establish_connection
   conn = self.transport.establish_connection()

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/transport/pyamqplib.py", line 245, in establish_connection
   connect_timeout=conninfo.connect_timeout)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/kombu/transport/pyamqplib.py", line 51, in __init__
   super(Connection, self).__init__(*args, **kwargs)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/amqplib/client_0_8/connection.py", line 125, in __init__
   self.transport = create_transport(host, connect_timeout, ssl)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/amqplib/client_0_8/transport.py", line 220, in create_transport
   return TCPTransport(host, connect_timeout)

 File "/data/www/addons.mozilla.org/zamboni/vendor/lib/python/amqplib/client_0_8/transport.py", line 58, in __init__
   self.sock.connect((host, port))

 File "<string>", line 1, in connect

error: [Errno 111] Connection refused
Thanks for the report.  I filed an IT bug separately while we debugged, but it fixed this problem so going to call this a dupe.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694474
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.