enable updates from FF3.6.23 -> FF5.0.1

VERIFIED FIXED

Status

Release Engineering
General
P2
normal
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: joduinn, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Users who are on FF3.6.23 who manually do CheckForUpdates should receive major updates to FF5.0. However, we just confirmed this is *not* in place. Currently, 3.6.23 users who manually do check-for-updates get "no updates available". 

This is not our usual mode of operation (we always want to leave an upgrade path available for users who go looking for an upgrade). We cant find anywhere any info
on whether this was intentional or not. Per email with legneato, asa, users on FF3.6.x who manually do check-for-updates should get FF5.0.

Note: It is known, and understood, by legneato that these users who upgrade to FF5.0 will then get prompted to move forward to the latest FF7.0.1. This is intentional, and is to avoid the overhead of re-writing and re-localizing the existing MU dialog prompts.
per irc from nthomas, we would prefer to do FF3.6.23 -> FF5.0.1.

We have the snippets for both, and we have the same MU for both. Unless there's an objection, we'd prefer to do FF3.6.23-->5.0.1.

(thanks for the good catch, nthomas!)
We never pushed out the 3.6.23 -> 5.0.1 updates to productions channels, probably because of the chempsill around 7.0. The 5.0.1 test snippets would have been up, but I don't think they had any QA, and have since been overwritten by the ones for 7.0.1.

Either way, both sets of snippets we have on hand use the new billboards
  https://www.mozilla.org/en-US/firefox/latest/details/from-3.6.html
instead of the old one
  https://www.mozilla.org/en-US/firefox/5.0/details/
We are still missing a few locales for the new (be, bn-IN, cy, fi, hy-AM, or, ta, vi, see bug 668108), but have said that fi is the only one we really have to have.

So, we can
1, regenerate snippets using old billboards, minimal QA, push to release/beta
2, try to finish off the important (or all) locales for the new billboard, use the existing 5.0.1 snippets, slightly more than minimal QA (billboard checks), push out
3, Do 2 only use the 7.0.1 snippets, most QA, since there's two extra versions of things that could be going wrong (data compatibility etc)

Sounds like 3 was ruled out in email, so Christian what's your preference out of 1 and 2 ?
Summary: (re?)enable updates from FF3.6.23 -> FF5.0 → enable updates from FF3.6.23 -> FF5.0.1

Comment 3

6 years ago
Let's do #1, pushing tomorrow (Friday PDT) if we have time
(In reply to Christian Legnitto [:LegNeato] from comment #3)
> Let's do #1, pushing tomorrow (Friday PDT) if we have time

I'm fine with this though I would prefer it to be an afternoon event.
I decided that we should just re-use some previous snippets, in particular the ones from the 3.6.20 -> 5.0.1 major update. Just needed to update the buildIDs and versions:

cd /opt/aus2/snippets/staging
for suffix in '' '-beta' '-test'; do
  rsync -a Firefox-3.6.20-build1-5.0.1-build1-MU${suffix}/ \
           Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard${suffix}/
  cd Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard${suffix}/Firefox/
  mv 3.6.20 3.6.23
  for d in 3.6.23/*; do
    mv $d/2* $d/20110920075126
  done
  cd ../..
done

Sanity check - comparing to Firefox-3.6.23-build1-5.0.1-build1-MU* has only changes like this:
-detailsUrl=https://www.mozilla.com/zh-TW/firefox/latest/details/from-3.6.html
+detailsUrl=https://www.mozilla.com/zh-TW/firefox/5.0/details/
(ie hashes, urls etc are unchanged)
ashughes, you can go ahead and QA on releasetest (or in RelEng speak, I've pushed Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard-test live).
Assignee: nobody → nrthomas
Priority: -- → P2
Tested on releasetest:
http://mozmill-release.brasstacks.mozilla.com/#/update/detail?branch=5.0&channel=releasetest&from=2011-10-10&to=2011-10-17&target=5.0.1

FYI, you will see an error like this in every testrun:
failed | /testDirectUpdate/test3.js | test3.js::testDirectUpdate_AppliedAndNoUpdatesFound | could not find element Elem instance. 

...this is a Mozmill issue with flipping branches mid-testrun, not an issue with the snippets.
Additionally, abillings checked the Billboard redirects from .com to .org and it appears good.
Christian/ashughes, when do you want to push this out ? I can do today, or after 1pm another day (or I can try to rope in someone in PDT/EDT).

Comment 10

6 years ago
(In reply to John O'Duinn [:joduinn] from comment #0)
> Note: It is known, and understood, by legneato that these users who upgrade
> to FF5.0 will then get prompted to move forward to the latest FF7.0.1. This
> is intentional, and is to avoid the overhead of re-writing and re-localizing
> the existing MU dialog prompts.

I thought that bug 668108 has created new billboards like http://www-trunk.stage.mozilla.com/en-US/firefox/latest/details/from-3.6.html so that we don't have exactly this problem any more? Is the issue that a handful of localizations for those might still be missing?
Lukas, thanks for handling the snippet push. The commands are

~/bin/backupsnip Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard
~/bin/pushsnip   Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard
~/bin/pushsnip   Firefox-3.6.23-build1-5.0.1-build1-MU-old_billboard-beta

This is going to be unadvertised - the throttling is already set up so no action needed there.
Assignee: nrthomas → lsblakk
pushed, QA'd.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
QA has signed off these updates on release and beta channel. I'm having issues with mail.mo right now so no email to r-d.
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.