testopia editparams.cgi logs "Argument isn't numeric" in VMethods.pm

RESOLVED DUPLICATE of bug 526197

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 526197
6 years ago
6 years ago

People

(Reporter: Don Lindsay, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 567242 [details]
params with testopia stuff pretty much defaulted

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110930134335

Steps to reproduce:

Using bugzilla-3.6.6-1.fc15.noarch and testopia-2.4-BUGZILLA-3.6.tar.gz, patched using the provided extensions/Testopia/patch-3.6.2 (but it also happens with the 3.6 patch)

As admin, browsed to the testopia parameters page. Noticed that the HTTPD error log gets an error message every time I try to Save, apparently regardless of which item I edit. I haven't tried editing every possible parameter (yet).


Actual results:

[Fri Oct 14 18:38:57 2011] [error] [client 10.250.221.124] [Fri Oct 14 18:38:57 2011] editparams.cgi: Argument "" isn't numeric in numeric comparison (<=>) at /usr/lib64/perl5/vendor_perl/Template/VMethods.pm line 493., referer: http://naslinux1/bugzilla/editparams.cgi?section=query

Looking at the code, this resembles 526197, except that that is marked Resolved, and looking at the code on my box, I see that the fix suggested in that case is present. Namely, something changed from 'nsort' to 'sort'.  So this has the same symptom but needs a different fix.

This happens every time, so I can investigate, if anyone can suggest a fix. I'm happy with hacking extra log printouts and the like.


Expected results:

No error. I assume this error is having consequences, which may or may not explain why I haven't been able to set up a testopia plan. (Clicking "New Plan" gives me an Internal Server Error web page, presumably because I haven't configured things right yet.)

If one of my parameters has an illegal value, I assume the design spec is to tell me which one. Not having recieved such, I guess I've encountered a bug.
Bug 526197 isn't fixed so if your problem is not due to your Testopia modifications (making this a Testopia bug) then your problem is most likely due to same Bugzilla problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526197
You need to log in before you can comment on or make changes to this bug.