Closed Bug 694748 Opened 9 years ago Closed 3 years ago

When I open Print Preview of the View Page Source, The Error console receives an error.

Categories

(Core :: Print Preview, defect, minor)

x86
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: alice0775, Unassigned)

References

Details

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/9545b88eed82
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111014 Firefox/10.0a1 ID:20111014030948

When I open Print Preview of the View Page Source,  The Error console receives an error.

This happens on Firefox4.0.1 to Nightly10.0a1

Reproducible: Always

Steps to Reproduce:
1. Start Firefox with clean profile
2  Open Web page (ex. http://www.mozilla.org/foundation/licensing/website-content.html ) 
3. Open Eoor Console (Ctrl+Shift+J)
4. Focus Browser
5. Open View Page Source (Ctrl+U)
6. Open Print Preview of the View Page Source (Aft f v)

Actual Results:

  The Error console receives an error.


Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.sessionHistory]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://global/content/bindings/browser.xml ::  :: line 755"  data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 762

Expected Results:
  No error

Regression Window(m-c)
Print preview doesn't work in view source:
http://hg.mozilla.org/mozilla-central/rev/19dbabe331ad
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100209 Minefield/3.7a2pre ID:20100209073221
Reproduced:
http://hg.mozilla.org/mozilla-central/rev/75beeb8eed5e
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a2pre) Gecko/20100210 Minefield/3.7a2pre ID:20100210071710
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=19dbabe331ad&tochange=75beeb8eed5e
Triggered By:
8f535b584531	Olli Pettay — Bug 544018 - print preview doesn't work in view source , r=dao
I couldn't reproduce this initially, but then I hit it after a few tries (and now I hit it consistently).  Not sure why it didn't happen the first few times.
This is still reproducible when trying to print the page source for google.com, and besides that, a blank page is displayed when "shrink to fit" option is selected.
Nightly 2013-01-11, win 7 x64, ubuntu 12.04 x86
Blocks: 521204
Attached image screenshot.png
This issue is also reproducible with the latest beta - Firefox 24 beta 5 (build ID: 20130822154523) on all platforms. 

Besides the results mentioned in comment 0, I also get what is shown in the attached screenshot.
(In reply to Paul Silaghi, QA [:pauly] from comment #2)
> This is still reproducible when trying to print the page source for
> google.com, and besides that, a blank page is displayed when "shrink to fit"
> option is selected.

I can't reproduce the blank page. If you still can, please file a separate bug on it, and have that one (not this one) block bug 521204.
No longer blocks: 521204
(Oh, I missed the "page source" part, sorry. I do get an effectively-blank page when print-previewing google's source. I've spun off a bug myself to cover that bug 960822.)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.