History: Filtering by month does not work

RESOLVED INCOMPLETE

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED INCOMPLETE
6 years ago
2 years ago

People

(Reporter: littarae, Unassigned)

Tracking

9 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 567301 [details]
"Juni" is june

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Visited history and filtered by months or 6 months ago


Actual results:

Visits from this week/month appeared


Expected results:

Visits from the selected months should appear
(Reporter)

Updated

6 years ago
Severity: normal → minor
that column is the global last visited date, not last visited date inside that month timeframe.
bug 381519 and bug 497202 cover that easy confusion
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

6 years ago
But I cannot see any visits within this month ...
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
So, the date points to this month, but the This Month container does not show a visit to that url?
Is that a download url or something different from a common visit?
(Reporter)

Comment 4

6 years ago
There are some unique visits, so that I never visited them again. These are normal visits like news, google-queries ... Additionally, there is none entry within the specified month, so that it is very curious that I visited every site again. I would expect at least only one entry with the right date...
Due to huge lags I cleared the history (which had shown just about 200 entries, too little number) and got a huge performance boost.
(In reply to littarae from comment #4)
> Due to huge lags I cleared the history (which had shown just about 200
> entries, too little number) and got a huge performance boost.

That's a known bug, will be fixed in Firefox 8.

Comment 6

6 years ago
Reporter -> Are you still experiencing this issue with Firefox 9.0.1?
(Reporter)

Comment 7

6 years ago
Yes. Unfortunately I think so. There are still some URLs for October which I visited in December firstly. Even with the older than six months filter I get some matches although I reinstalled Windows on my SSD in September.

Perhaps the Sync-feature is responsible for this bug? I am constanty facing an error (freely translated from German: "Sync - Error with sync: Unknown error. Sync will try again automatically [#button#: Sync now]"). Two PCs (Win7) are syncing everything but passwords (not used). I can see recent bookmarks and superbar-previously-visited-suggestions on both systems.


If neccessary I can take screenshots or give a list of the items, but I would like to censor some private data (Logins, Names and some PHP-parameters)

Comment 8

6 years ago
Can you try reproducing in Safe Mode or a new Profile? If you can reproduce in a new profile can you document each step you take (i.e. 1) Load new profile 2) visit example.com 3) look in history - no visit listed)

Safe Mode -> http://support.mozilla.com/en-US/kb/Safe+Mode

New Profile -> http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
Version: 7 Branch → 9 Branch
(Reporter)

Comment 9

6 years ago
Safe mode does not solve the problem.

I cannot reproduce the issue in a new profile easily. Firefox behaves as I expect it to do (changing Windows date -> visits shown correctly, it even has an second entry in the month I switched to when page still opened). About ten visits tested.

Additionally, I looked for my brand-new subnotebook. It is synced with the build-in feature (cf. error comment #7) and has the same issue in history. Unfortunately, I resetted my old notebook to factory settings and have only a complete backup (so I cannot easily check its history).


So, the problem seems to be related to sync or at least sync transfers the data that creates the problem.


PS: Some facts are very strange in my eyes ... I cannot believe, that I just had 25 visits in 10 days (no holidays) and never checked my mail-accounts during this time...
I don't think we can easily debug this, it could indeed just be history synced by another device
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → INCOMPLETE

Updated

2 years ago
Blocks: 1231521
You need to log in before you can comment on or make changes to this bug.