If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fails to use attributes in <col> tag

RESOLVED DUPLICATE of bug 915

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 915
6 years ago
6 years ago

People

(Reporter: dr.kral, Unassigned)

Tracking

7 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

The html <col> tag does not process all valid attributes.  The similar bugs reported are from 2005 and earlier.  


Actual results:

The <col> is suppose to modify a table display.  Only some attributes work.

There is an example at http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_col_test which illustrates the problem -- note nothing is right justified.  However some attributes, such as width, are processed.


Expected results:

text should be right justified in column three but is not.

It works in Opera 11and IE
It fails in Chrome, Safari (for windows)

Comment 1

6 years ago
Thanks for the re(In reply to dr_kral from comment #0)
> The html <col> tag does not process all valid attributes.
Not in HTML 5 
> The similar bugs reported are from 2005 and earlier.
Indeed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915

Comment 2

6 years ago
Sorry, should read:

(In reply to dr_kral from comment #0)
> The <col> is suppose to modify a table display.
Not in HTML5

Comment 3

6 years ago
(In reply to j.j. from comment #1)
> Thanks for the re(In reply to dr_kral from comment #0)
> > The html <col> tag does not process all valid attributes.
> Not in HTML 5 

HTML 4 is still alive, not ?

Comment 4

6 years ago
It's mostly possible with CSS, trivial example:
   https://bug915.bugzilla.mozilla.org/attachment.cgi?id=156716
More advanced examples can be solved with other properties (you can use it together with <col> attributes), e.g.:

https://developer.mozilla.org/en/CSS/:first-child
https://developer.mozilla.org/en/CSS/:last-child
https://developer.mozilla.org/en/CSS/:nth-child
https://developer.mozilla.org/en/CSS/:nth-last-child
https://developer.mozilla.org/en/CSS/:first-of-type
https://developer.mozilla.org/en/CSS/:last-of-type
https://developer.mozilla.org/en/CSS/:nth-of-type


Relevant for implementors is HTML 5. It's designed to be backwards compatible.
Former presentational attributes should be covered by CSS.

> HTML 4 is still alive, not ?

Not really (a related discussion is in bug 680532).

But bug 915 isn't INVALID or WONTFIX for that reason. Patches accepted, see bug 915 comment 288, bug 915 comment 347.

Comment 5

6 years ago
It's possible if the number of column don't change. I use CSS in this case, but on a generate table, I use one "class" by cell, is not possible to use selectors (except if the CSS is also generate).

Comment 6

6 years ago
That's why I said "mostly possible"
You need to log in before you can comment on or make changes to this bug.