Interfaces to address book resources(nsIAbDirectory and nsIAbCard) contain methods specific to the mork database implementation.

VERIFIED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Cuchulainn, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

17 years ago
Interfaces to address book resources
(nsIAbDirectory and nsIAbCard) contain methods
specific to the mork database implementation.
As a consequence is not possible to have mutiple
types of address book implementation (such as LDAP).
To enable new types of address book implemention
the interfaces and code need to be refactored into
specific and non-specific functionality. In addition
this should make it easier to replace the existing
mork implemention if so desired.
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Interfaces to address book resources (nsIAbDirectory and nsIAbCard) contain methods specific to the mork database implementation. → Interfaces to address book resources(nsIAbDirectory and nsIAbCard) contain methods specific to the mork database implementation.
(Assignee)

Comment 1

16 years ago
Created attachment 29613 [details] [diff] [review]
change in xpfe/communicator/resources/content
(Assignee)

Comment 2

16 years ago
Created attachment 29617 [details] [diff] [review]
changes in mailnews/absync
(Assignee)

Comment 3

16 years ago
Created attachment 29618 [details] [diff] [review]
Changes in mailnews/addrbook
(Assignee)

Comment 4

16 years ago
Created attachment 29619 [details] [diff] [review]
Changes in mailnews/compose
(Assignee)

Comment 5

16 years ago
Created attachment 29620 [details] [diff] [review]
Changes in mailnews/import

Comment 6

16 years ago
test builds for windows and mac are at:
http://ftp.mozilla.org/pub/mozilla/nightly/experimental/ldap-69480/
(Assignee)

Comment 7

16 years ago
Mozilla.mac.sea is not self-extracting.  You need to use stuffit to open it 
and make it self-extactable.  This is best I can do for posting the Mac test 
build.  Please post in the bug or email me if anyone have problem extracting it.

Comment 8

16 years ago
So do we have any testing done on the builds available?
(Assignee)

Comment 9

16 years ago
This is the testing result from Fenella's email.

---------------------
Hi all,

I have unzipped the following build and ran the following basic functionalities 
on Address Book.   If you want more testings other
than what's listed, please let me know.

1. Visual of Directory pane, result pane and card view pane. 
2. Add  new card, delete card, edit card and close card and cancel card. And 
also modify card properties in the Personal and
Collected address book. Drag cards between collected and personal address book
3. Open, edit, cancel and close card dialog
4. Add new list, edit list, add cards to list and delete card in the mailing 
list, and close and delete mailing list
5. Create new address book and delete address book. 
6. Add card and  list to new address book. Delete list and card from the new 
address book
7. Auto complete
8. Import Address book
9. Migrate address book
10. Test of  all submenus of File, Edit and View in the Address Book window
11. Use of all toolbar menus in the Address Book
12. Running Address book in Classic theme. When I was using an old profile, 
after I switch to classic theme, and relaunch, I was
unable to open Address Book. However, after I migrated a new profile, I do not 
see any problem opening the Address book
window. 

Result:   No crash.  basic functionalities works fine.
Only find one new bug,  which is:
In the card view pane, when clicking on the email address, unable to open the 
Compose window.

I believe this is a regression. No bug filed for this before (At least I cannot 
find it)

Fenella
----------------

I tried the regression bug she mentioned with the same build,  I can't reproduce 
it.  I can open compose window using New Msg button or the menu in address book. 
 
(Assignee)

Comment 10

16 years ago
The bug Fenella mentioned is an existing bug 72213,  Not a regression bug.

Comment 11

16 years ago
we haven't been able to get a test build for linux posted... i'll do a test 
build today with the patches in this bug.

Comment 12

16 years ago
having some patch conflicts in nsAbSync.cpp... perhaps you can resolve?

    310   // If we failed before, fall back to the non-parented modal dialog
    311   if (NS_FAILED(rv))
    312   {
    313     nsCOMPtr<nsIPrompt> dialog;
    314     nsCOMPtr<nsIWindowWatcher> wwatch(do_GetService("@mozilla.org/embedc
omp/window-watcher;1"));
    315     if (wwatch)
    316       wwatch->GetNewPrompter(0, getter_AddRefs(dialog));
    317 
    318     if (!dialog)
    319       return NS_ERROR_FAILURE;
    320     rv = dialog->Alert(nsnull, msg);
    321   }

Comment 13

16 years ago
looking at the changes to nsAbSync.cpp, it seems like danm's change is the one 
that should go in... attempting a linux build with his changes, and yours.
(Assignee)

Comment 14

16 years ago
Created attachment 30247 [details] [diff] [review]
New patch for absync to resolve conflict

Comment 15

16 years ago
Linux bits, with danm's change:
http://ftp.mozilla.org/pub/mozilla/nightly/latest-69480/

Comment 16

16 years ago
Hey, dan, can you take a look at the last patch to nsAbSync.cpp and give a 
review for the resolution with the merge to your change?
(Assignee)

Comment 17

16 years ago
QA test result on Linux build.   It is correct that Mozilla build won't do the 
migraing for address book.

Email from Fenella.
---------------------------------------
I ran the same tests as I did for win32 (see list below).  Everything else runs 
fine except for item 9,
which is Migrate Address Book. 
Steps: 
1.  Migrate a profile 
2. Open Address Book, it lists Personal Address Book and Collected Address Book. 
Actual result: Both bool look blank.  The card and list in the 4.7 profile did 
not get migrated. . 
I observe that In the console window, it says:  the addressbook migrator is only 
in the commercial
builds 

If you need additional tests, please let me know. 
-------------------------------------
This can be resolved fixed because it already landed, right?

Comment 19

16 years ago
Martin, can you verify dmose's last comment, that this bug can be marked FIXED
because it's already in current nightly builds?  If you can marked FIXED, it
goes to QA to verify, which is goodness.
(Reporter)

Comment 20

16 years ago
This code refactoring work has landed!
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: esther → stephend
verified fixed using lxr and bonsai via code verification.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.