Last Comment Bug 694802 - VC11 cannot compile nsWindow.cpp because it #includes <pbt.h>
: VC11 cannot compile nsWindow.cpp because it #includes <pbt.h>
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: x86 Windows 8
: -- normal (vote)
: mozilla10
Assigned To: :Ehsan Akhgari (busy, don't ask for review please)
:
Mentors:
Depends on:
Blocks: VC11
  Show dependency treegraph
 
Reported: 2011-10-15 17:38 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2011-10-25 04:58 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (818 bytes, patch)
2011-10-15 20:58 PDT, :Ehsan Akhgari (busy, don't ask for review please)
netzen: review+
Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2011-10-15 17:38:38 PDT
This header was added in bug 464091.  We no longer support Windows CE, and on other versions of Windows, #including windows.h is enough.  The SDK headers shipping with VC11 no longer include this file.
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-15 20:58:55 PDT
Created attachment 567313 [details] [diff] [review]
Patch (v1)
Comment 2 Brian R. Bondy [:bbondy] 2011-10-23 05:12:38 PDT
Are you using Windows SDK 8.0 by the way or 7.0|7.1?
Comment 3 Brian R. Bondy [:bbondy] 2011-10-23 05:14:24 PDT
I assume you ar eusing Windows SDK 8 because the file is already included in 7.0 and 7.1.
Comment 4 Brian R. Bondy [:bbondy] 2011-10-24 12:35:54 PDT
Comment on attachment 567313 [details] [diff] [review]
Patch (v1)

Review of attachment 567313 [details] [diff] [review]:
-----------------------------------------------------------------

- Verified that I get the problem building with VC2011 on Win7 and Windows SDK v7.1 and that the patch fixes it.
- Verified that it doesn't cause a problem with VS2010 w/ 7.1
- Did not try other supported setups but I think it will be OK.
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-24 12:58:21 PDT
(In reply to Brian R. Bondy [:bbondy] from comment #2)
> Are you using Windows SDK 8.0 by the way or 7.0|7.1?

Sorry for the late reply.  I'm getting the problem with the SDK version shipping with VC2011 (I believe they call it 8.0).
Comment 6 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-24 12:59:42 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/34bf415c96bb
Comment 7 Brian R. Bondy [:bbondy] 2011-10-24 13:12:50 PDT
You can tell by the way when you run start-msvc11.bat it will output something like:
Windows SDK version: 7.1
Comment 8 Brian R. Bondy [:bbondy] 2011-10-24 13:20:25 PDT
Also just out of curiosity are you using a 64bit machine?

If so does the developer preview put anything inside your Program files directory? Or only Program Files (x86)?

For me:
C:\Program Files\Microsoft SDKs\Windows 
has v7.0 and v7.1 folders

But:
C:\Program Files (x86)\Microsoft SDKs\Windows has
has v7.0A, v8.0 and v8.0A folders
Comment 9 :Ehsan Akhgari (busy, don't ask for review please) 2011-10-24 14:31:00 PDT
(In reply to Brian R. Bondy [:bbondy] from comment #8)
> Also just out of curiosity are you using a 64bit machine?

Yep, a 64-bit VM.

> If so does the developer preview put anything inside your Program files
> directory? Or only Program Files (x86)?
> 
> For me:
> C:\Program Files\Microsoft SDKs\Windows 
> has v7.0 and v7.1 folders
> 
> But:
> C:\Program Files (x86)\Microsoft SDKs\Windows has
> has v7.0A, v8.0 and v8.0A folders

As far as I can tell, everything goes under Program Files (x86).
Comment 10 Marco Bonardo [::mak] 2011-10-25 04:58:50 PDT
https://hg.mozilla.org/mozilla-central/rev/34bf415c96bb

Note You need to log in before you can comment on or make changes to this bug.